4

Maybe it's not a tough question but I'm not very practiced in magento, I hope you can help me :)

I installed a theme (unero, for those who know it) for magento V.1.9.3.6 that gives the possibility to create a multilingual site. I would like the default language to be Italian, so I deactivated all the other available languages.

Unfortunately, if I disable the English language, which is the default one, the site becomes unreachable. In fact, the English language has id: 1 (and is in bold) as you can see from the screenshot.

enter image description here

How can I set Italian to language which ALL users land (independently of geolocation)?

Of course the general options (ex: default country, locale options... are all setted on "Italy") Should I create a dedicated website or store?

Thanks for your help!

4

To accomplish your demand, first you have to change your Default Store View, then set Locale option for that Default Store View.

1) Change Default Store View from English to Italian

Go to System > Manage Stores, then select a Store

Then select Store View that matches your Italian Store View

Change store view

2) Set Locale Option in System > Configuration > General

Then change Configuration scope (Italian), uncheck the Use Website then select language in Locale

Set Locale option

NB: It's showing English and Francais on the images but it should be Italian in your case. And this is for English language of backend interface, if you are using an Italian interface, it may vary

0
  1. I dont know why do you want to disable the english language ?, keep all the languages and you just have set the right code in your store view and in general as default language.

  2. For Geo localisation you want to redirect customer automatically to a specific store according to his language, you have to use a GeoIp ! take a look to this tuto.

0

First thing is why Store name is blank? if you click on store (middle row) it will open a form. In that form you can set default store view in your case "Italy". Select Italy from the Default Store View field.

0

Thank you all for your help, unfortunately I can not make it. I think it's something related to my theme, because - as Rakesh Varma rightly said the store name is empty and it should not be. I will try to contact the assistance of the theme, thanks to everyone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.