5

I am using Magento 2.2.2. In the past, I used to get the message below in every time I log in as an admin:

Failed to synchronize data to the Magento Business Intelligence service. Retry Synchronization

I have run a command line and disabled the above message, I disabled the Synchronization, I don't remember what was the command line. Now I am trying to enable the advanced reporting and I have applied all of what is written in the documentation: http://docs.magento.com/m2/ce/user_guide/reports/advanced-reporting.html

I still cannot get any report. I only get the image below. How can I enable the synchronize data to the Magento Business Intelligence service via a command line to reverse what I've done so that I can get the reports?

enter image description here

  • Have you get the solution ? For enabling the Advanced Reporting . – Hafiz Arslan May 2 at 6:30
2

You probably just disabled the module via command line.

Try this:

php bin/magento module:enable Magento_Analytics

and then run

php bin/magento setup:di:compile

php bin/magento setup:upgrade

And make sure that you have enabled Advanced Reporting in:

Admin -> Stores -> Configuration -> General -> Advanced Reporting

  • When I tried the first command line, I have gotten: No modules were changed. Advanced reporting is enabled – sam Jan 8 '18 at 23:06
  • magento module:status shows all modules are enabled – sam Jan 8 '18 at 23:23
  • I don't think you can affect this module by any other CLI command, unless you disabled your cron job. When enabled, this module makes an attempt to contact the Business Intelligence server every 1 hour for 24 hours until it succeeds. And sends data at the designated time in Configuration -> General -> Advanced Reporting. Maybe you just have to wait a little bit... I can't recommend anything else but to check your Cron job and make sure you have everything necessary for this module to work (described in docs.magento.com/m2/ce/user_guide/reports/…) – Lez Jan 8 '18 at 23:31
  • I thought about doing the same! I have to wait until after the time specified under "Time of day to send data". I checked under Reports>Marketing Automation> Cron Tasks and the tasks are running there. I will wait and see.. – sam Jan 8 '18 at 23:36
  • It never worked even after waiting until GMT 2:00 AM! – sam Jan 9 '18 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.