0

I am having issue with setting up website on https from http. I am using Magento ver. 2.1.9.

Current Settings:
web/unsecure/base_url --> http:// .......
web/secure/base_url --> https://...........
web/secure/use_in_frontend --> 1
web/secure/use_in_adminhtml --> 1

Issue Magento admin login page -- The page is redirecting too many times.

Magento Front -- All the URLs like navigation links & form actions are still using http. And customer login page is redirecting too many times which leads to page crash.

Thanks in advance

0

You can try to set web/unsecure/base_url to https://... - in practice I've never experienced any issue if doing so since usually store owners, when owning a SSL certificate, are willing to secure all URLs anyway. Furthermore you should check for any rewrite rules in you .htaccess/vhosts/webspace panel that may be responsible for the http->https (or https->http in your case?) redirects.

  • Thanks, I have already tried it but it didn't work for me the change after doing this was that homepage was also getting too many redirects. – Sarvagya Jan 8 '18 at 9:32
  • checked your webspace config as well? Usually these panels come with options to allow you to directly redirect for example from http to https. – Christoph Farnleitner Jan 8 '18 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.