9

enter image description hereAfter data migration process I see that orders data is not displayed in Magento admin sales grid.

All data is available in the database. Than why data is not in sales grid?

Anyone has idea about this problem?

1

3 Answers 3

28

Disable Asynchronous indexing under Store > Configuration > Advance > Developer > Grid Settings

enter image description here

Clear cache (optional reindexing) or set up a cron job.

7
  • hello, @Adnan, Already asynchronous indexing is disabled in my case, but still grid is not showing for me May 6, 2019 at 12:46
  • 1
    @jafarpinjar what is your magento version?
    – Adnan
    May 8, 2019 at 18:45
  • additionally, please, if you have upgraded from previous version of Magento then completely clear the cache and run the reindex, double check that Async Indexing is disabled from config.
    – Adnan
    May 8, 2019 at 18:46
  • @Adnan i am getting the error "Something went wrong with processing the default view and we have restored the filter to its original state." can u please advise Aug 20, 2019 at 6:31
  • 1
    @NagarajuKasa where you are facing the error, on sales order grid? If you have made any change to sales order grid (e.g. third-party extension or customization) please remove them, flush the cache, clear generated/code directory if the error resolves then put back your customization one by one and see when the error triggers again, it will help you to debug the issue.
    – Adnan
    Aug 28, 2019 at 9:31
1

Disable Async Grid Indexing

As mentioned in the other answer, you can disable it by going to

Store > Configuration > Advance > Developer > Grid Settings > Asynchronous indexing

You can do the same from the command line:

View the settings value: bin/magento config:show dev/grid/async_indexing

Enable: bin/magento config:set dev/grid/async_indexing 1

Disable: bin/magento config:set dev/grid/async_indexing 0

Run Cron Job

It is not recommended to disable async grid indexing as it might degrade the performance.

The grid updates are done by the scheduled cron job.

The best solution would be to run the cron job at regular intervals.

Or, you can also run cron job manually via the following command:

bin/magento cron:run

After that, refresh cache: bin/magento cache:flush

Ref: https://docs.magento.com/user-guide/sales/order-grid-updates-schedule.html

0

Try to use this tool https://github.com/trunglv/mage2_dev

Example:

Build for all missing orders

sudo bin/magento beta_dev:build_order_grid --missing-orders true

Build for a specific order -- In case you want to refresh just one item due to just missing a few fields.

sudo bin/magento beta_dev:build_order_grid --missing-orders [order_id]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.