1

I was working on the Magento 2 CE, in which Data Migration Tool was already installed. I cleared the root folder and installed fresh Magento 2 EE in that folder. I also truncated the database of CE and import the fresh database of EE.

So at this point, everything is new and fresh. There is no third party module in it. But when I run the site, I get this weird error:

Setup version for module 'Magento_DataMigrationTool' is not specified

I don't know what's wrong with it. Why is system thinking that I had installed Data Migration Tool? (Same-store is working fine in my local system.)

I then tried to place Data Migration Tool explicitly in vendor/magento/ and inserted an entry in setup_module and config.php but I am still getting the same error.

(I am running Magento on nginx)

3
  • go to root directory of your magneto and type php bin/magento setup:upgrade then your issue will be resolved. Commented Jan 4, 2018 at 9:05
  • i did this several times but nothing happened.
    – umair ayub
    Commented Jan 4, 2018 at 9:28
  • give enough permission to DataMigrationTool directory and then run upgrade command again. Commented Jan 4, 2018 at 9:40

2 Answers 2

1

Could you please try the following code. please go to root installation folder and fire following command

magento module:disable Magento_DataMigrationTool

Than clear cache , do re indexing and provide proper permission

Let me know if you have still any issue

4
  • output of command: Unknown module(s): 'Magento_DataMigrationTool'
    – umair ayub
    Commented Jan 4, 2018 at 9:11
  • Could you please make sure that it is not appear when you fire following command php bin/magento setup:upgrade just check it out Commented Jan 4, 2018 at 9:16
  • Also make sure that you need to do var and cache after this process Commented Jan 4, 2018 at 9:19
  • It does not appear in the list against upgrade command. I also cleared var and cache.
    – umair ayub
    Commented Jan 4, 2018 at 9:22
0

Ran the following command which fixed that issue:

service php7-fpm reload

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.