2

I am using the command to upgrade 2.2.2 but getting this problem, how can I do, thank you!please help!

composer update

Running composer as root/super user is highly discouraged as packages, plugins and scripts cannot always be trusted

Loading composer repositories with package information

Updating dependencies (including require-dev)

Nothing to install or update

Package sjparkinson/static-review is abandoned, you should avoid using it. Use phpro/grumphp instead.

Generating autoload files

update

composer require sjparkinson/static-review
Running composer as root/super user is highly discouraged as packages, plugins and scripts cannot always be trusted Using version ^5.2 for sjparkinson/static-review ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/product-community-edition 2.2.2 requires sjparkinson/static-review ~4.1 -> satisfiable by sjparkinson/static-review[4.1.0, 4.1.1] but these conflict with your requirements or minimum-stability.
    - magento/product-community-edition 2.2.2 requires sjparkinson/static-review ~4.1 -> satisfiable by sjparkinson/static-review[4.1.0, 4.1.1] but these conflict with your requirements or minimum-stability.
    - magento/product-community-edition 2.2.2 requires sjparkinson/static-review ~4.1 -> satisfiable by sjparkinson/static-review[4.1.0, 4.1.1] but these conflict with your requirements or minimum-stability.
    - Installation request for magento/product-community-edition 2.2.2 -> satisfiable by magento/product-community-edition[2.2.2].


Installation failed, reverting ./composer.json to its original content.
3

This is not an error, only a warning. The abandoned package still exists, it's just recommended to be replaced. Also it is a developer tool, not needed for Magento to operate.

When you ran composer require sjparkinson/static-review, composer tried to install the latest version, but Magento requires an older version. Just don't do this, it's not necessary.

Your actual problem is something else: composer update alone won't update Magento, because in composer.json Magento itself is locked to a specific version. That's why you get the "Nothing to install or update" message. You have to replace the required version of magento/product-community-edition in composer.json.

This can also be done on the command line:

composer require magento/product-community-edition 2.2.2 --no-update
composer update

If you update from Magento 2.1, read more here: Upgrade Magento from 2.1 to 2.2.1 with sample data using composer (leave out the "sampledata" commands if you don't use the sample data)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.