0

I'm having a fight with the readiness check at the moment. The only error I have to fix is the one below but I have no clue at the moment.

Please assist if you can.

Command "update" failed: Loading composer repositories with package information

[Composer\Downloader\TransportException] 
The "https://repo.magento.com/packages.json" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages: 
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed 
Failed to enable crypto 
failed to open stream: operation failed 


update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [packages1] ... [packagesN]

Currently running: TLS 1.2 with ssl 3.1 Cannot change this due to shared hosting.

0

A solution is to disable the TLS by editing the composer.json and adding:

"config": {
    "disable-tls": true,
    "secure-http": false
}    

This is a solution that works for shared webhosters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.