3

I created a custom module in Magento 2 and then tried to package it for submitting it to the Magento marketplace. I followed this link in order to create a composer file and packaging of the module:

After the packaging and submission of the module in Marketplace, the module was rejected from the technical review with Installation Errors as below,

Command: 
composer require vendor/module:1.0.0' 
Installation issue: 
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for vendor/module 1.0.0 -> satisfiable by vendor/module[1.0.0].
- Conclusion: remove magento/framework 100.0.19
- Conclusion: don't install magento/framework 100.0.19
- vendor/module 1.0.0 requires magento/framework ~100.1.10 -> satisfiable by magento/framework[100.1.10, 100.1.11].
- Can only install one of: magento/framework[100.0.19, 100.1.10].
- Can only install one of: magento/framework[100.0.19, 100.1.11].
- Installation request for magento/framework (locked at 100.0.19) -> satisfiable by magento/framework[100.0.19].

Installation failed, reverting ./composer.json to its original content.
[Pipeline] }
[Pipeline] // stage
[Pipeline] sh
[DockerOperationsPHP70Magento21CEVarnish] Running shell script
+ echo Failure 

On searching I found the below link that has the same issue as mine but the solution could not much help me out here.

Also, I developed the module in magento 2.1.1. Is there anything that I am doing wrong? Do I need to change the magento/framework in my composer.json file to something else? My Composer file is as below,

{
  "name": "vendor/module",
  "description": "This is the description of the module.",
  "type": "magento2-module",
  "version": "1.0.0",
  "license": [
    "OSL-3.0",
    "AFL-3.0"
  ],
  "require": {
    "magento/framework": "~100.1.10"
  },
  "authors": [
    {
      "name": "Vendor",
      "email": "test@testing.com",
      "homepage": "http://www.test.com/",
      "role": "Developer"
    }
  ],
  "autoload": {
    "files": [ "registration.php" ],
    "psr-4": {
      "Vendor\\Module\\": ""
    }
  }
}

Conclusion: don't install magento/framework 100.0.19

What does this mean? I am not using the 100.0.19 anywhere, then why am I getting this error?

I am in a real trouble wit this. Can anyone please help?

  • Did you manage to fix this? – coderunner Jan 4 '18 at 8:59
1

The error you get is a standard composer output. You specified that your module relies on magento/framework package with versions >= 100.1.0 and < 100.2.0.

Marketplace verification just trying to ensure that your extension will be compatible with few latest versions. These versions have different framework version inside, because Magento always increase the minor version(second digit) of framework for every minor release.

Thus, you just need to change the version requirement to "magento/framework": "~100.1" or 100.*.*. For more information refer to https://getcomposer.org/doc/articles/versions.md#tilde-version-range-

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.