I would like to change the workflow type to client side, but when I navigate to this configuration option, it tells me that this option is not available in production mode. enter image description here I've set magento to developer mode with magento deploy:mode:set developer multiple times, I've cleared everything in var/cache, var/view_preprocessed, pub/static and cleaned the cache, but no change. I've also set it to production mode and then back to developer mode, that didn't help either. Last but not least I just changed the config in app/etc/config.php and imported the config, but then the app just keeps telling me The configuration file has changed. Run app:config:import or setup:upgrade command to synchronize configuration. I don't know what else to try, can somebody help?

1 Answer 1


the comment "not available in production mode" is just a hint, that this setting will not be used in production mode - developer mode will not make this field editable.

So setting the developer mode with the console command was the correct first step. To verify if developer mode is enabled you can use the following command:

bin/magento deploy:mode:show

The field being not enabled / greyed out is another thing from the pipeline deployment feature, introduced with magento 2.2.

You can change the setting via a console command:

bin/magento config:set --lock dev/front_end_development_workflow/type client_side_compilation 
  • thanks, deploy:mode:show shows that the mode is set to developer. I just noticed that my whole config tree seems to be locked somehow. I can't uncheck any of the Use system value checkboxes and other changes just don't take effect, although I get a confirmation after saving the config. Is it possible to lock/unlock the whole config tree?
    – leah
    Jan 2, 2018 at 17:09
  • ok, that seems to be why: magento.stackexchange.com/questions/196912/…. I could set it with config:set and then dump the config again, all good. Thanks a lot.
    – leah
    Jan 2, 2018 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.