1

I was deleting the categories that came with a theme I purchased for Magento 2, and adding in my own, but now when I visit the site I get this error:

Exception #0 (Magento\Framework\Exception\NoSuchEntityException): No such entity with id = 233
5
  • try to remove deleted category from products and reindex. Dec 28, 2017 at 6:03
  • It may be due to some of products are still having that same category which you have deleted. Dec 28, 2017 at 6:08
  • The products are all new products I created and I didn't select categories for them
    – cvassios
    Dec 29, 2017 at 17:20
  • I have the same issue and already tried to reindex. But still get an error. Any help? Jun 1, 2018 at 9:45
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review Jun 1, 2018 at 10:11

1 Answer 1

1

My store had a reference to a deleted category in the catalog_category_product_index table. The following SQL solved the issue.

DELETE FROM catalog_category_product_index WHERE category_id = 233;

(substitute the ID from your error at the end)

1
  • Unfortunately I decided to start from scratch, so I'm unable to verify if this would have been a fix, but hopefully somebody else will come across this and it can help them. Sounds like a possible solution
    – cvassios
    May 20, 2018 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.