1

I just updated php to PHP 7.1.12-3+ubuntu17.10.1+deb.sury.org+1 (cli) (built: Dec 14 2017 15:40:13) ( NTS )and when i try to readiness check for magento2, i am getting error that PHP Version Check Your PHP version is 7.1.11-0ubuntu0.17.10.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6. Hide detail

I got that it allows on these versions http://devdocs.magento.com/guides/v2.0/install-gde/prereq/php-ubuntu.html

I have tried different solutions given http://devdocs.magento.com/guides/v2.0/install-gde/prereq/php-ubuntu.html

sudo apt-get -y update
sudo add-apt-repository ppa:ondrej/php
sudo apt-get -y update
sudo apt-get install -y php7.0 libapache2-mod-php7.0 php7.0 php7.0-common php7.0-gd php7.0-mysql php7.0-mcrypt php7.0-curl php7.0-intl php7.0-xsl php7.0-mbstring php7.0-zip php7.0-bcmath php7.0-iconv php7.0-soap

I have no idea, how to install 2 version of php or if i remove php7 and install php5 then whether any new issue will come. please help me to resolve the issue..I am using Ubuntu 17.10 & Magento 2.1

0

You need to install php version 7.0.6–7.0.x if you want to use latest version of PHP supported by magento 2. As magento 2 readiness check clearly dictates that your php version is not supported. Please downgrade you PHP version.

It seems like you have installed php 7.0 version but forgot to disable 7.1 and enable 7.0. Please enter these commands after php 7.0 installation.

$ sudo a2dismod php7.1
$ sudo a2enmod php7.0
$ sudo service apache2 restart
0

If you see here your version of PHP is not supported yet. http://devdocs.magento.com/guides/v2.0/install-gde/prereq/php-ubuntu.html Please degrade to lower version.

Please refer below link to downgrade the PHP version.

https://tecadmin.net/downgrade-php-on-ubuntu/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.