1

Initial Setting:

  1. HTTP only
  2. SEO Url Turned off

What was changed:

  1. Turned on SEO Url to remove index.php from Url
  2. Turned on SSL for Admin and Frontend.

Issue:

  1. 404 Error messages
  2. Unable to login to magento admin

Resolution Attempt:

I tried to reverse the changes that i made, as i was unable to access admin. I did it through database, phpmyadmin.

  1. Restored the Base URL settings in core_config_data set: web/secure/base_url to http://www.domain.com/ web/unsecure/base_url http://www.domain.com/

  2. Turned off URL Rewrites from database: set value for web/seo/use_rewrites to "0"

  3. Turned off SSL for frontend and admin web/secure/use_in_adminhtml 0 web/secure/use_in_frontend 0 web/secure/offloader_header SSL_OFFLOADED [this is as originally]

  4. Cleared var/cache and var/session removed the contents of both these folders.

  5. Reindexded the Catalog urls by running php -f indexer.php -- -reindex catalog_url

Current State:

  1. Homepage loads fine.
  2. Product URLs do not have index.php in them. causing 404. When i add index.php in the url the product loads fine.
  3. Some menu items on homepage have index.php vs some don't.
  4. Admin: goes forcefully to https
  5. Admin:404 message. the url forces to https.
  6. htaccess file remains unchanged, i have checked with a diff of htaccess backup.
  7. Htaccess rule for enable rewrite is as "Options +FollowSymLinks RewriteEngine on"

Will appreciate help to have this fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.