4

I've installed Magento 2 on AWS, however, the admin page is appearing like this:

enter image description here

What should I do?

Thanks!

4
  • we can get the better idea if you could forward the console log error and which server you are using (apache/nginx) ? Dec 22, 2017 at 6:49
  • apache. where can I get this log error?
    – cmsantos
    Dec 22, 2017 at 11:28
  • in browser press F12 key, I have doubt you have deleted the .htaccess file of pub/static, you can place this file inside `pub/static' github.com/magento/magento2/blob/2.2/pub/.htaccess Dec 22, 2017 at 12:10
  • I've checked the .htaccess file on pub/static and it's there
    – cmsantos
    Dec 22, 2017 at 12:18

4 Answers 4

1

Open /etc/apache2/apache2.conf

Find <Directory /var/www/html>

Replace rules inside with below rules.

<Directory /var/www/html/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

Restart server and you are done.

8
  • This had worked for me.
    – P S
    Dec 22, 2017 at 8:00
  • hi, I've already tried this and it's still the same
    – cmsantos
    Dec 22, 2017 at 11:13
  • What is the path of your magento 2 directory?
    – Meetanshi
    Dec 22, 2017 at 11:16
  • /var/www/html/magento2
    – cmsantos
    Dec 22, 2017 at 11:28
  • I have updated a answer. please check and do change there.
    – Meetanshi
    Dec 22, 2017 at 12:20
0

dependent on your languages you are working with redeploy

php bin/magento setup:static-content:deploy en_GB en_US 

just to add some meat to this answer

http://devdocs.magento.com/guides/v2.1/config-guide/cli/config-cli-subcommands-static-view.html

1
  • hi, I've already tried this and it's still the same
    – cmsantos
    Dec 22, 2017 at 11:13
0

Please follow below steps for resolve issue.

1)php bin/magento setup:upgrade
2)php bin/magento setup:static-content:deploy (add language en_GB if your default language is not englishg)
3)chmod -R 755 pub;chmod -R 755 var; (set permission)
9
  • hi, I've already tried this and it's still the same
    – cmsantos
    Dec 22, 2017 at 11:13
  • check pub/static folder have any htaccess file ? if not then please add htaccess file form default magento setup , may be issue due to missing htaccess file Dec 22, 2017 at 11:18
  • can I copy the .htaccess file from root to this folder?
    – cmsantos
    Dec 22, 2017 at 11:25
  • I've copied the file and it's still the same
    – cmsantos
    Dec 22, 2017 at 11:29
  • no , please download fresh magento and then copy pub/static/ htaccess file Dec 22, 2017 at 11:29
0

Follow below steps and i am sure it will work:

1) Open .htacess, find and comment Options FollowSymLinks e.g #Options +FollowSymLinks

2) Deploy content by using the command: php bin/magento setup:static-content:deploy

3) Set permissions : chmod -R 777 var/ pub/static pub/media

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.