8

I install Aschroder_SMTPPro but mail not send it gives error

Warning: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed in C:\xampp\htdocs\charge\lib\Zend\Mail\Protocol\Smtp.php on line 206

Anyone Have solution For this ??

SSL Support Is also enable http://prntscr.com/hp1c9g

3
  • Its issue related to SSL not working properly on your server. Please check below URL stackoverflow.com/questions/26827192/…
    – Nits
    Dec 21, 2017 at 4:52
  • im using it in local Dec 21, 2017 at 7:04
  • Do you use a virtual host like "mysite.magento.local"? Or is it just localhost? Also how did you generate your openssl certificate? And to what host does it point? Dec 27, 2017 at 8:53

2 Answers 2

4

Download cacert.pem file from following link https://curl.haxx.se/docs/caextract.html

open php.ini file

and paste following path in php.ini file

openssl.cafile="c:/xampp/cacert.pem"

0

I was also having similar issue with Aschroder_SMTPPro but installed another extension and it worked, find extension link below:

https://github.com/magepal/magento2-gmailsmtpapp

3
  • its for Magento2 , im getting error in magento1 Dec 25, 2017 at 5:30
  • Ohh Isee, missed to check right Magento version. Have you tried with different smtp ports i.e. 25, 465 and 587? Dec 25, 2017 at 10:17
  • no there is no any port issue just open scrrenshot and show error Dec 26, 2017 at 3:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.