0

We are using Magento 2 for our website. We have used Bluehost with 2GB RAM, 5TB Memory. Bluehost called me yesterday to change the server because of the huge bandwith. We have currently 1000 products in our website. And we need to add 5000 products in future. Server team told us to check the website for taking huge bandwidth. We planned to check the website in local system(Ubuntu 17.10 8GB RAM, 1TB Memory).

Allocated memory size was exhausted when we run website in local system(Ubuntu 17.10). We changed the memory_limit, phpuploadsize, postmaxsize to -1. But this time system getting hanged when we run website and execute any magento ssh commands reindex, cache flush, clean commands.

What is the main reason for this cause? How do i check it?

  • First disable the deploy mode from developer to production. – Salma Saiyad Dec 18 '17 at 6:20
  • turn on developer mode now i can access backend. But front end shows error Exception #0 (Exception): Warning: file_put_contents(/opt/lampp/htdocs/website/pub/static/frontend/Sm/topzstore/en_US/css/config_4.css): failed to open stream: No such file or directory in /opt/lampp/htdocs/website/app/design/frontend/Sm/topzstore/Magento_Theme/templates/html/complie_less.phtml on line 107 – Tamil Selvan Dec 18 '17 at 9:55
  • It is due to incorrect file permission to your magento. Please follow below link to reset proper permission. devdocs.magento.com/guides/v2.0/install-gde/prereq/… – Salma Saiyad Dec 18 '17 at 10:06
  • i deployed content using -f. now its working. but category pages shows Element 'referenceContainer', attribute 'class': The attribute 'class' is not allowed. – Tamil Selvan Dec 18 '17 at 12:01
  • Yes Please remove it as this is not supported in newer magento 2.2.x version – Salma Saiyad Dec 19 '17 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.