1

I am trying to install magento 1 in ubuntu 16.04LTS with PHP version 7.02. But I'm getting an error as below:

CONNECT ERROR: Package community/Mage_All_Latest 1.9.3.7: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1 Package community/Interface_Adminhtml_Default 1.9.3.7: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1 Package community/Interface_Frontend_Default 1.9.3.7: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1 Package community/Interface_Install_Default 1.9.3.7: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1 Package community/Mage_Downloader 1.9.3.7: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1 Package community/Mage_Centinel 1.9.3.7: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1 Package community/Interface_Frontend_Base_Default 1.9.3.7: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1 Package community/Phoenix_Moneybookers 1.9.3.7: requires PHP version>= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1 Package community/Mage_Compiler 1.9.3.7: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.22-0ubuntu0.16.04.1

This is the first time I'm working with magento 1. At beginning of the installation the PHP version and module check showed everything fine. But this error is blocking the installation. Please help.

1

Magento 1.9.X PHP Requirements

That's strange that the PHP check seemed to be fine, Magento 1.9.X i don't think is officially compatible with PHP 7.02 and requires one of the following versions:

  • PHP 5.6
  • PHP 5.5
  • PHP 5.4

http://docs.magento.com/m1/ce/user_guide/magento/system-requirements.html

Compatibility Module

You can get it working however i have a few instances running on PHP 7 and it only required some small changes and the sites have worked fine for over a year.

Check the below this may be of assistance:

Magento 1.9.x php 7 support

Inchoo have a module that takes care of those modifications although i have not tested this.

  • 1
    How can I run this particual project using php 5.6 because I need php7 for rest of my projects. – Purushotam Sangroula Dec 18 '17 at 4:55
  • I had to install php 5.6 in my server since it is compatible with both magento 1 and 2. I made it working. I have not tested Inchoo's module that you have suggested. – Purushotam Sangroula Dec 18 '17 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.