3

I am getting the following error when trying to run the initial php setup script, please advise

$ php bin/magento setup:install
Fatal error: Declaration of Zend\Mvc\Controller\PluginManager::get($name, ?array $options = NULL) must be compatible with Zend\ServiceManager\AbstractPluginManager::get($name, $options = Array, $usePeeringServiceManagers = true) in /srv/http/magento/vendor/zendframework/zend-mvc/src/Controller/PluginManager.php on line 211

My Setup:

$ php -version
  PHP 7.2.0 (cli) (built: Dec  5 2017 18:56:10) ( NTS )
  Copyright (c) 1997-2017 The PHP Group
  Zend Engine v3.2.0, Copyright (c) 1998-2017 Zend Technologies
2

I think the problem is with the PHP Version and the Zend Framework. You can refer this link

I think if you downgrade your PHP version there will be no problem in installing.

| improve this answer | |
0

i had that with php 7.0.25 and apache 2. after rebooting, setup worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.