5

I want to hide the store switcher of the top of my page. I'm using Magento 2.1.9 How can I do this? enter image description here

3
  • 1
    Are you talking about default theme or any purchased template
    – Aman Alam
    Dec 13, 2017 at 16:47
  • I updated the post. I'm using a purchased template called "Everything". So I guess I have to ask the template creator?
    – Núria
    Dec 13, 2017 at 16:49
  • 1
    You can use this solution add this line <referenceBlock name="store_language" remove="true"/> in /app/design/frontend/YourPackage/YourTheme/Magento_Theme/layout/default.xml
    – Aman Alam
    Dec 13, 2017 at 16:53

4 Answers 4

1

Under

/public_html/app/design/frontend/vendor/theme/Magento_Theme/web/css/source

you create a file called:_extend.less

add this code in it:

.switcher select
{
display:none
}

Clear your cache afterwards and it should works. If it doesn't, maybe the CSS Selector is wrong, so you have to find the correct one.

The effect of this addition is that the Language switcher will not be rendered, it will still get loaded by your Magento.

3
  • Easiest tweak ! Good Dec 14, 2017 at 5:06
  • 3
    Not a good solution as it will just hide it using CSS. Why render unnecessary HTML elements on page when those are not used. Better remove it using layout updates.
    – Arvind07
    Jul 30, 2019 at 5:56
  • 1
    Easy tweak, bad solution.
    – John
    Feb 12, 2020 at 7:01
6

For Magento 2, you can hide the store switcher by removing the store_switcher block. To remove the store_switcher block, extend the Magento_Theme default.xml file by creating the default.xml in your theme: app/design/frontend/your_vendor_name/your_theme_name/Magento_Theme/layout/default.xml

In the default.xml file:

<body>    
   <referenceBlock name="store_switcher" remove="true"/>
</body>

Then clear cache: bin/magento cache:clean

0

For Magento 2 you can disable it via your customer theme folder. In your file app/design/frontend///Magento_Theme/layout/default.xml you can add the line between the tag

...
<body>
    <referenceBlock name="store_switcher" remove="true"/>
...

Flush the cache afterwards.

0

For me, using the Ultimo theme for Magento 2, after I added a new Store View this dropdown appeared on the frontend with an ID of "switcher-language". To remove it, I made the following changes to this file:

  • app/design/frontend/THEME/CHILD/Magento_Theme/layout/default.xml
  1. Added to bottom: <referenceBlock name="store_language" remove="true"/>

  2. Commented out this section: <block class="Magento\Store\Block\Switcher" name="store_language.mobile" template="switch/languages.phtml"> <arguments><argument name="id_modifier" xsi:type="string">mobile</argument?</arguments></block>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.