2

I am trying to install magento2 on xampp server and get these errors: these PHP extensios are not available:

PHP Extension xsl. PHP Extension intl. PHP Extension soap.

Please tell me how to remove these errors.

2 Answers 2

1

The error you are getting is quite common with beginners during magento 2 installation. It is better to follow this documentation. The error you are seeing in your installation process means that your server lacks php xsl,intl and soap extension. You must install these according to your php version. To check the php extensions installed in your server use this command in terminal.

php -m

To enable your intl extension you must locate your php.ini file and uncomment this line: ;extension=php_intl.dll by removing semicolon at the beginning.

Similarly for other two extensions uncomment .i.e remove semi-colon at the beginning.

;extension=php_xsl.dll

;extension=php_soap.dll

To see it's effect you need to restart your xampp server.

If you do not know where your php.ini file is located then:

For Windows, you can find the file in the C:\xampp\php\php.ini-Folder (Windows) or in the etc-Folder (within the xampp-Folder).

Under Linux, most distributions put lampp under /opt/lampp, so the file can be found under /opt/lampp/etc/php.ini.

3
  • its not working. i removed the "!".
    – pooja
    Dec 10, 2017 at 11:55
  • did you restart your xamp server? Make sure you have those modules enabled or installed by using command php -m
    – P S
    Dec 11, 2017 at 2:40
  • You are welcome.
    – P S
    Dec 11, 2017 at 6:16
0

These PHP Extension xsl. PHP Extension intl. PHP Extension soap. extensions are by default disabled in php configuration file (php.ini)

To install magento2, we need to enable these extensions: To do this in Windows:- Go to C:\xampp\php\php.ini edit this php.ini file in the text editior and remove the semicolon at the beginning of following lines:

;extension=php_intl.dll

;extension=php_soap.dll

;extension=php_xsl.dll

If the above lines are not available in php.ini file then below lines must be available

;extension=intl

;extension=soap

;extension=xsl

Remove the semicolon at the beginning of these lines and Save the php.ini file, stop and start Apache again

Cheers !!

Thank You !!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.