2

How do I remove this prefix field from the checkout in Magento 2.2?

enter image description here

When Googling this it appears there used to be an admin setting that has since been moved/removed:

enter image description here

Update - I don't have the Show Prefix option

enter image description here

  • 2
    You can set No from dropdown in Stores -> Configuration -> Customer -> Customer Configuration -> Name and Address Options. – Rakesh Jesadiya Dec 5 '17 at 11:59
  • I don't have that option @RakeshJesadiya - I've added a screenshot of the options I have – Ben Crook Dec 5 '17 at 13:06
  • i am checking in 2.2.0 – Rakesh Jesadiya Dec 5 '17 at 13:29
1

For the enterprise version of Magento:

For those who comes here from google and do not seen corresponding field in the store configuration:

You can check the Magento_CustomerCustomAttributes module where the fields street_lines, prefix_show, middlename_show, suffix_show, dob_show, taxvat_show, gender_show are disabled in the file magento/module-customer-custom-attributes/etc/adminhtml/system.xml. With that module all this attributes with its settings available now in the:

Stores > Attributes > Customer

and

Stores > Attributes > Customer Address

menu view

There you can set up the attribute's visibility and another options:

visibility options

Then if you already set up prefix/suffix options in the Name and Address Options:

name and address options / prefix options

you will see the prefix as dropdown on the frontend (checkout):

prefix dropdown in address form on checkout

| improve this answer | |
0

Login on admin panel go to Stores -> Configuration -> Customer -> Customer Configuration

Change Prefix to no under the Name and Address options Stores -> Configuration

Customer -> Customer Configuration

Change the Prefix to no under the name and address options

| improve this answer | |
  • What version of Magento are you on? I don't have that option – Ben Crook Dec 5 '17 at 13:04
  • I've updated my question with a screenshot of my name and address options tab – Ben Crook Dec 5 '17 at 13:05
0

@Athul Vijayan that is only for customer registration form and it is not there anymore in the newer versions.

The Path is in Stores-> (Settings)Configuration -> Customers (tab) -> Customer Configuration -> Name and Address Options -> Show Prefix.

There is an image to show it.

prefix

Set them to no, and clear the cache.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.