0

I get this error when upgrading my back up Magento 2.

How I can fix this error ? and which module need Imagick ?

My server's OS is CentOS

3

You need to install the PHP imagick module on your server, for CentOS you should be able to use:

sudo yum install php-imagick

To install the module.

If that doesn't work, you can follow: https://www.scalescale.com/tips/nginx/install-imagemagick-php-imagick-centos/

Installing on CentOS 6: https://www.vultr.com/docs/install-imagemagick-on-centos-6

8
  • 1
    No package php-imagick available. – gh darvishani Dec 5 '17 at 8:51
  • Edited my answer. You can also try sudo yum install php7-imagick (Depends on your PHP version) – Matt Antley Dec 5 '17 at 8:52
  • No package php7-imagick available. i don't know why i get this error – gh darvishani Dec 5 '17 at 8:56
  • Have you tried using the tutorial link in my answer? – Matt Antley Dec 5 '17 at 8:57
  • i am trying ... and same error ... – gh darvishani Dec 5 '17 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.