1

I have Magento 2.2.0 setup with sample data. I am trying to setup Magento 2.1.10 with Sample Data for reference. However, when running:

php bin/magento sampledata:deploy

I get:

Loading composer repositories with package information
Updating dependencies (including require-dev)

Problem 1
    - The requested package magento/module-bundle-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 2
    - The requested package magento/module-catalog-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 3
    - The requested package magento/module-catalog-rule-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 4
    - The requested package magento/module-cms-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 5
    - The requested package magento/module-configurable-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 6
    - The requested package magento/module-product-links-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 7
    - The requested package magento/module-customer-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 8
    - The requested package magento/module-downloadable-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 9
    - The requested package magento/module-grouped-product-sample-data could not be found in any version, there may be a typo in the package name.
  Problem 10
    - The requested package magento/module-msrp-sample-data could not be found in any version, there may be a typo in the package name.
  ...

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.
There is an error during sample data deployment. Composer file will be reverted.

Composer tries to fetch the version 100.1.* for these modules but can't find it. (For reference it tries and successfully gets version 100.2.* for Magento 2.2.0.

Any ideas or thoughts on getting the sample data via composer in Magento 2.1.10?

0

I have tried this in mangeto 2.2:-

here /var/www/html/magento2/ is your root project path:-

php bin/magento setup:perf:generate-fixtures /var/www/html/magento2/setup/performance-toolkit/profiles/ce/small.xml

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.