1

When visitors to our website try to fill in our contact form on our contact page, they are sent to /contact/index, and receive the error Unable to submit your request. Please, try again later.

At Magento Configuration, I see: enter image description here

If I change Enable to Yes, I see a different form, which doesn't work.

I can't change it back to No now - it is stuck on Yes.

Web hosting support say:

No errors are being generated and saved to server logs. I can see that any issue that exists occurs in the contact form application itself, as the mail server never receives any request to send email from it.

Access logs showing contact form usage: 185.93.231.8 - - [27/Nov/2017:09:42:39 +1100] "POST /contacts/index/post/ HTTP/1.1" 302 606 "http://example.com/contacts/index/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36"

I'd really appreciate some suggestions on how to troubleshoot this.

2
  • have you configure email setting in admin end?
    – Abdul
    Commented Dec 2, 2017 at 12:33
  • How do I do this please @Abdul ?
    – Steve
    Commented Dec 3, 2017 at 1:52

1 Answer 1

1

This error usually comes because of the server which has not configured for sending email. If you check var/log/exception.log, you will see this error Zend_Mail_Transport_Exception: Unable to send mail. mail(): Failed to connect to mailserver ....... .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.