2

I am new to Magento. I have installed Magento 2.1.10 successfully and now I am trying to install extension to it. I got a free extension from the market place and while installing it, I am finding the following error in the readiness check.

  1. Wrong version of PHP
  2. PHP Settings Check *

Your current PHP memory limit is 128M. Magento 2 requires it to be set to 756M or more.

I have already set my memory_limit to 2G in the ini file. Wamp Server selected version is 7.0.6

Here is the screenshot of the readiness page

readiness page

Here PHP version is 5.6.25, but my selected version is 7.0.6. Please help me get ride of these errors. Any help/suggestion us appreciated. Thank you

0

Go to your Php.ini in your Wampp/Php folder & search for memory_limit set it to 2048M & save the file stop your Wampp server & restart the Wampp Server & try Again.

Be sure that after making your php version to 7.0.10 again restart your server.

For better information run your info.php file into your server & look for the active configurations are matching your requirements or not

Go to Magento Directory opened cmd/terminal there & Run these three commands in cmd/terminal. To run the cron separately.

Php bin/magento cron:run

php update/cron.php

php bin/magento setup:cron:run

Try to run the readiness check again.See for the reference Magento doesn't check php version

If still facing some problem feel free to ask

Thank You!

  • Thank you for the advice, i have done as you suggested but onrunning the final command on the command prompt I am getting the following error. Can you please suggest what to do?? [Exception] Warning: ini_get() expects exactly 1 parameter, 2 given in C:\wamp64\www\project\setup\src\Magento\Setup\Model\PhpRe adinessCheck.php on line 192 – ratul keot Dec 4 '17 at 4:41
  • The file name is PhpReadinessCheck.php & over there on line number 192 put this thing $currentMemoryLimit = ini_get('memory_limit'); – Abhishek Tripathi Dec 4 '17 at 4:54
  • Then try to again run the above command & if still facing any issue feel free to revert back – Abhishek Tripathi Dec 4 '17 at 4:55
  • Hi again, I changed the line from $currentMemoryLimit = ini_get('memory_limit', '2048M'); to $currentMemoryLimit = ini_get('memory_limit'); but still not working. I am having the same issue. And also I have completed the previous steps successfully. – ratul keot Dec 4 '17 at 8:43
  • Update: Magento have passed the readiness check, but the PHP version is still wrong. It is still showing 5.6.25 instead of 7.0.6 – ratul keot Dec 4 '17 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.