0

I create a new custom module for Magento 2 and I can't install it through composer. This is the error:

Your requirements could not be resolved to an installable set of packages.

      Problem 1
        - The requested package mycustom/module could not be found in any version, there may be a typo in the package name.
      Problem 2
        - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (5.6.32) or value of "config.platform.php" in composer.json does not satisfy that requirement.
        - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (5.6.32) or value of "config.platform.php" in composer.json does not satisfy that requirement.
        - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (5.6.32) or value of "config.platform.php" in composer.json does not satisfy that requirement.
        - Installation request for magento/framework == 101.0.0.0 -> satisfiable by magento/framework[101.0.0].

    Potential causes:
     - A typo in the package name
     - The package is not available in a stable-enough version according to your minimum-stability setting
       see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

    Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

    Installation failed, reverting ./composer.json to its original content.

This is my composer.json file:

{
    "name": "mycustom/module",
    "description": "New module for test",
    "require": {
        "php": "~5.5.22|~5.5.23|~5.5.24|~5.5.25|~5.5.26|~5.5.27|~5.5.28|~5.5.29|~5.5.30|~5.5.31|~5.5.32|~5.5.33|~5.5.34|~5.5.35|~5.5.36|~5.5.37|~5.5.38|~5.6.0|~5.6.1|~5.6.2|~5.6.3|~5.6.4|~5.6.5|~7.0.2|~7.1.0|~7.1.1|~7.1.2|~7.1.3|~7.1.4|~7.1.5|~7.1.6|~7.1.7|~7.1.8",
        "mycustom/module-parent": "*"
    },
  "authors": [
    {
      "name": "Name Lastname",
      "email": "email@example.com",
      "homepage": "http://www.example.com/",
      "role": "Developer"
    }
  ],
    "type": "magento2-module",
    "version": "1.0.0",
    "minimum-stability": "alpha",
    "prefer-stable": true,
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "autoload": {
        "files": [
            "registration.php"
        ],
        "psr-4": {
            "Mycustom\\Module\\": ""
        }
    }
}

How I can solve this issues?

Thank you

2

Please use PHP version in your composer.json file.

"php": "~5.5.0|~5.6.0|~7.0.0|7.0.2|7.0.4|~7.0.6|~7.1.0"

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.