4

As the subject says, after applying the SUPEE-10415 patch, all seems fine until "redis-cli flushall" then we get the annoying "404 error: Page not found." on everything. After a process of elimination, disabling extensions as magento devdocs suggested, nothing seemed to change until we removed the cache tags from the local.xml file.

Curious if anyone has any "ah hah" idea why everything works fine without redis but 404s when it's enabled.

If it's any significance here is the code that I have that only works when removed from the local.xml after patching.

    <cache>
      <backend>Mage_Cache_Backend_Redis</backend>
      <backend_options>
        <server>127.0.0.1</server>
        <port>6379</port>
        <persistent></persistent>
        <database>0</database>
        <password></password>
        <force_standalone>0</force_standalone>
        <connect_retries>1</connect_retries>
        <read_timeout>10</read_timeout>
        <automatic_cleaning_factor>0</automatic_cleaning_factor>
        <compress_data>1</compress_data>
        <compress_tags>1</compress_tags>      
        <compress_threshold>20480</compress_threshold>
        <compression_lib>gzip</compression_lib>
      </backend_options>
    </cache>
  • In the release notes for v1.9.3.7 (aka SUPEE-10415) there's a section on known issues which includes the 404 problem, have you looked into this? – Danny Nimmo Nov 30 '17 at 22:22
  • What are the steps you have taken to solve this issue? – zus Dec 16 '17 at 11:18
3

I'd give https://magento.stackexchange.com/a/203746/41117 a read.

I had a similar issue when testing SUPEE-10415 and having Redis enabled, if you revert SUPEE-10415 and enable the Developer logs within System > Configuration > Developer > Log Settings and try redis-cli flushall again you should have a PHP warning that points to the root issue, or Redis points to the issue itself (In my case it was a connection issue).

Once you resolve the PHP warning then Redis will function as usual with SUPEE-10415 applied.

  • Step in the right direction - it was my inept ability to pay attention before to: Warning: Redis::pipeline(): Already in pipeline mode in /lib/Credis/Client.php on line 931 After updating pecl-redis, which I should had done a while ago, it fixed all issues and seems to be fine after patching as well. – Timotheos Dec 1 '17 at 16:18
  • Glad you sorted it! – Matt Antley Dec 1 '17 at 16:19
  • 10415 return 404 error, no redis configured, may i know the possibilities of error? – zus Dec 16 '17 at 12:06
  • Unless it's a configuration similar to mine in the OP, I'm not certain that I could help. From what I do understand though, it was a conflict (somewhere) with PHP. Once I updated PHP, I could patch and things went fine. – Timotheos Dec 18 '17 at 15:12
  • @MattAntley After install SUPEE-10415, both front-end and back-end getting 404 error, how can i solve the error? magento.stackexchange.com/q/215620/57334 – zus Mar 3 '18 at 4:43
0

For me, It's just Cm_Cache_Backend_Redis line 235 try to check if class Credis_Cluster exist or not.

elseif (class_exists('Credis_Cluster') && array_key_exists('cluster', $options) && !empty($options['cluster'])) {
        $this->_setupReadWriteCluster($options);
    }

Which class is missing in my library. Updating Credis to latest version resolved it.

0

In my case I was only able to install SUPEE-10415 after installing SUPEE-10266. I hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.