2

Installation: MAMP Pro: 4.2 Magento 1.9.X

everything is working perfectly on the local machine, however when I view the site on mobile iPhone, connected to the same network. I get an error: Not Found - The requested URL /php.fcgi/index.php was not found on this server.

I've already disabled URL rewrites under System > Configuration > web. I've also checked .htaccess and it seems fine.

Here is my .htaccess

      ############################################
  ## uncomment these lines for CGI mode
  ## make sure to specify the correct cgi php binary file name
  ## it might be /cgi-bin/php-cgi

  #    Action php5-cgi /cgi-bin/php5-cgi
  #    AddHandler php5-cgi .php

  ############################################
  ## GoDaddy specific options

  #   Options -MultiViews

  ## you might also need to add this line to php.ini
  ##     cgi.fix_pathinfo = 1
  ## if it still doesn't work, rename php.ini to php5.ini

  ############################################
  ## this line is specific for 1and1 hosting

      #AddType x-mapp-php5 .php
      #AddHandler x-mapp-php5 .php

  ############################################
  ## default index file

      DirectoryIndex index.php

  <IfModule mod_php5.c>

  ############################################
  ## adjust memory limit

  #   #php_value memory_limit 64M
      #php_value memory_limit 256M
      #php_value memory_limit 512M
      php_value memory_limit 1024M
      #php_value max_execution_time 18000

  ############################################
  ## disable magic quotes for php request vars

      #php_flag magic_quotes_gpc off

  ############################################
  ## disable automatic session start
  ## before autoload was initialized

      #php_flag session.auto_start off

  ############################################
  ## enable resulting html compression

      ##php_flag zlib.output_compression on

  ###########################################
  # disable user agent verification to not break multiple image upload

      #php_flag suhosin.session.cryptua off

  ###########################################
  # turn off compatibility with PHP4 when dealing with objects

      #php_flag zend.ze1_compatibility_mode Off

  </IfModule>

  <IfModule mod_security.c>
  ###########################################
  # disable POST processing to not break multiple image upload

      SecFilterEngine Off
      SecFilterScanPOST Off
  </IfModule>

  <IfModule mod_deflate.c>

  ############################################
  ## enable apache served files compression
  ## http://developer.yahoo.com/performance/rules.html#gzip

      # Insert filter on all content
      ###SetOutputFilter DEFLATE
      # Insert filter on selected content types only
      #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

      # Netscape 4.x has some problems...
      #BrowserMatch ^Mozilla/4 gzip-only-text/html

      # Netscape 4.06-4.08 have some more problems
      #BrowserMatch ^Mozilla/4\.0[678] no-gzip

      # MSIE masquerades as Netscape, but it is fine
      #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

      # Don't compress images
      #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

      # Make sure proxies don't deliver the wrong content
      #Header append Vary User-Agent env=!dont-vary

  </IfModule>

  <IfModule mod_ssl.c>

  ############################################
  ## make HTTPS env vars available for CGI mode

      SSLOptions StdEnvVars

  </IfModule>

  <IfModule mod_rewrite.c>

  ############################################
  ## enable rewrites

      Options +SymLinksIfOwnerMatch
      RewriteEngine on

  ############################################
  ## you can put here your magento root folder
  ## path relative to web root

      #RewriteBase /magento/

  ############################################
  ## uncomment next line to enable light API calls processing

  #    RewriteRule ^api/([a-z][0-9a-z_]+)/?$ api.php?type=$1 [QSA,L]

  ############################################
  ## rewrite API2 calls to api.php (by now it is REST only)

      RewriteRule ^api/rest api.php?type=rest [QSA,L]

  ############################################
  ## workaround for HTTP authorization
  ## in CGI environment

      RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

  ############################################
  ## TRACE and TRACK HTTP methods disabled to prevent XSS attacks



  ############################################
  ## redirect for mobile user agents

      #RewriteCond %{REQUEST_URI} !^/mobiledirectoryhere/.*$
      #RewriteCond %{HTTP_USER_AGENT} "android|blackberry|ipad|iphone|ipod|iemobile|opera mobile|palmos|webos|googlebot-mobile" [NC]
      #RewriteRule ^(.*)$ /mobiledirectoryhere/ [L,R=302]


  ## SECURITY REWRITE ###
      RewriteCond %{REQUEST_URI} ^.*/DOWNLOADER [OR,NC]

      RewriteCond %{REQUEST_URI} ^.*/RSS/CATALOG [OR,NC]

      RewriteCond %{REQUEST_URI} ^.*/RSS/ORDER [NC]

      RewriteCond %{REMOTE_ADDR} !^1.2.3.4

      RewriteCond %{REMOTE_ADDR} !^5.6.7.8

      RewriteRule ^(.*)$ http://%{HTTP_HOST}/ [R=302,L]

  ## END SECURITY REWRITE ###

  ############################################
  ## always send 404 on missing files in these folders

      RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

  ############################################
  ## never rewrite for existing files, directories and links

      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteCond %{REQUEST_FILENAME} !-l

  ############################################
  ## rewrite everything else to index.php
      RewriteCond %{REQUEST_URI} ^.*/ADMIN_PANEL_LOCATION [OR,NC]

      RewriteRule .* index.php [L]

  </IfModule>


  ############################################
  ## Prevent character encoding issues from server overrides
  ## If you still have problems, use the second line instead

      AddDefaultCharset Off
      #AddDefaultCharset UTF-8

  <IfModule mod_expires.c>

  ############################################
  ## Add default Expires header
  ## http://developer.yahoo.com/performance/rules.html#expires

      ExpiresDefault "access plus 1 year"

  </IfModule>

  ############################################
  ## By default allow all access

      Order allow,deny
      Allow from all

  ### TEMPORARY LOCKDOWN ###
  #order deny,allow
  #deny from all
  #allow from xxx.xxx.xxx

  ###########################################
  ## Deny access to release notes to prevent disclosure of the installed Magento version

      <Files RELEASE_NOTES.txt>
          order allow,deny
          deny from all
      </Files>

  ############################################
  ## If running in cluster environment, uncomment this
  ## http://developer.yahoo.com/performance/rules.html#etags

      #FileETag none

  ###########################################
  ## Deny access to cron.php
      <Files cron.php>

  ############################################
  ## uncomment next lines to enable cron access with base HTTP authorization
  ## http://httpd.apache.org/docs/2.2/howto/auth.html
  ##
  ## Warning: .htpasswd file should be placed somewhere not accessible from the web.
  ## This is so that folks cannot download the password file.
  ## For example, if your documents are served out of /usr/local/apache/htdocs
  ## you might want to put the password file(s) in /usr/local/apache/.

          #AuthName "Cron auth"
          #AuthUserFile ../.htpasswd
          #AuthType basic
          #Require valid-user

  ############################################

          Order allow,deny
          Deny from all

      </Files>

  #SetEnv MAGE_IS_DEVELOPER_MODE "true"
  • is your site hosted on server (not on MAMP) ? – Abhishek Panchal Nov 30 '17 at 18:52
  • @AbhishekPanchal Its a local MAMP Pro installation – lvekua Nov 30 '17 at 20:09
2

If on the same network, set your mobile device to use your server proxy. In your mobile WiFi setting, set the proxy to your-server-ip:80. 80 is the default http port. You need change it if you used other port. Then you could visit your site on your mobile.

| improve this answer | |
  • You are awesome, thank you so much. At first everything was loading fine except, all pages lead me to 404, then I had to change the browser url to remove the port numbers and everything started to work perfectly. – lvekua Dec 1 '17 at 5:03
  • 1
    @lvekua You are welcome :) Yes, the browser url doesn't need port number. Port number just needs in the WiFi proxy setting. – Key Shang Dec 1 '17 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.