4

after patching SUPEE-10415, saving products in backend causes an error,

Unsupported data type N

does it have to do something with the database? maybe some settings there?

any advice would be really helpfull

9

See: Security Patch SUPEE-10415 - Possible Issues?

You basically need to have SUPEE-8788 V2 installed.

Failing that download Magento 1.9.3.7 and copy

  • lib/Unserialize/Parser.php
  • lib/Unserialize/Reader/Arr.php
  • lib/Unserialize/Reader/ArrValue.php
  • lib/Unserialize/Reader/Null.php

files from that installation to your site and see if there are any changes between the files and overwrite them if there are.

  • 8788 v2 was installed allready but i installed it again but it doesn´t make a difference – Gery Nov 30 '17 at 14:18
  • yes, they are differnet, should i update this files then? – Gery Nov 30 '17 at 15:16
  • this solved the situation, many thanks for your help Matt!! – Gery Nov 30 '17 at 15:39
2

I had the same problem on Magento 1.9.2.4. Rolled back all SUPEE patches until the version SUPEE 8787 V1 (including this one) according to the

app/etc/applied.patches.list

and installed SUPEE-8788 V2 instead. Then installed all the patches again and the exception was gone.

Compared the files

  • lib/Unserialize/Parser.php
  • lib/Unserialize/Reader/Arr.php
  • lib/Unserialize/Reader/ArrValue.php
  • lib/Unserialize/Reader/Null.php

with the files from the version 1.9.3.7 and the content was the same, except comments in the file headers

0

Also encountered similar problem (Unsupported data type N) on CE 1.9.2.4 after applying 10415 - this was on saving shopping cart rules in admin & on the front end the user was presented w/ rule couldn't be applied.

I overwrote the lib/Unserialize/ files from 1.9.3.7 & now all is good - shopping cart rules can be saved & applied as expected.

Thanks Matt Antley

PS - if you just apply the lib/Unserialize/ files from SUPEE-8788 V2 you'll get a class not found error

0

My solution for magento 1.9.1.0

  • Download Magento ver 1.9.3.1
  • Copy folder lib/Unserialize from ver 1.9.3.1 to 1.9.1.0

and works :)

an some cases you can not revert patches. Just fix bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.