1

We are running into some strange errors with our Magento 2.1.9 installation. When opening a edit product page in the backend, the page shows some different inline errors:

Unable to resolve the source file for 'adminhtml/Magento/backend/nl_NL/Magento_Ui/templates/form/components/single/switcher.html' #0

 [path-to-magento-public]/vendor/magento/framework/App/StaticResource.php(97): Magento\Framework\View\Asset\File->getSourceFile() #1
 [path-to-magento-public]/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\StaticResource->launch() #2
 [path-to-magento-public]/pub/static.php(13): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\StaticResource)) #3 {main}

There are numurous errors on the page, all related to the adminhtml/Magento/backend/nl_NL/Magento_Ui/templates/form/components/single reference.

I've been trough the loop a few times here with the following commands:

php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy

And even more. I've cleared caches, removed di/generation folders, switched deployment modes back and forth, but still no luck.

I'm running out of ideas here, so I was hoping someone ran into the same problem and managed to find the culprit. I've added a screenshot to give you guys/gals some reference.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.