0

I am trying to update Amasty Layered Navigation. Following their documentation it says to type in the command-

composer update amasty/shopby

When I do that it says

Package "amasty/shopby" listed for update is not installed. Ignoring. 

It is installed and functions properly. When I run a status to see if it is enabled it is in there. Am I using the wrong command?

I can see the repo username and password in the auth.json file.


Update:

The extension was originally installed by ftp, meaning I had to update by using ftp. If anyone knows how to update an extension with composer after installing with ftp I would be curious.

0

The extension was originally installed by ftp, meaning I had to update by using ftp. If anyone knows how to update an extension with composer after installing with ftp I would be curious.

Remove the files from app/code, then use composer to install the new version:

composer require amasty/shopby

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.