After a PHP upgrade to 7.1 my ssh (Magento) Commands are not executed anymore...

See picture below

enter image description here

  • Did you update the path in your bash command after the update? If you run php -v what does it return? – Eirik Nov 26 '17 at 19:44
  • ea-php-cli Copyright 2017 cPanel, Inc. PHP 7.1.11 (cli) (built: Nov 7 2017 04:14:15) ( NTS ) Copyright (c) 1997-2017 The PHP Group Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.0.3, Copyright (c) 2002-2017, by ionCube Ltd. with Zend OPcache v7.1.11, Copyright (c) 1999-2017, by Zend Technologies – Jilco Tigchelaar Nov 26 '17 at 19:47
  • 1
    Since the php is running it almost sounds like a permissions issue. I'm assuming you installed with a lower version of php then updated. I'm sorry but that is outside of my level of knowledge. Only thing I can think of is to update the file/folder permissions using the php bash and see if that helps. – Eirik Nov 26 '17 at 19:54
  • Thanks, permissions seem to be okay (755). In my test they are the same and there the commands are working – Jilco Tigchelaar Nov 26 '17 at 20:02

I figured out that when i use the whole PHP pad, that it works. So

****/usr/bin/php bin/magento module:status works fine (The stars can be filled in with the exact pad if nescesarry)

Why this is is the next question, i'll keep you informed

UPDATE: It was because of to low memory settings in the new PHP.ini

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.