3

Having an issue with my exception.log, it keeps firing these errors. I understand (i think) it has something to do with an xml block with eyemagine and expression engine. Which files should i specifically look into? Is this just a broken syntax or is it not being named correctly?

2017-11-20T15:10:09+00:00 ERR (3): 
exception 'Mage_Core_Exception' with message 'Invalid block type: Mage_Page_Block_Html_Top' in /var/www/code/www.oop.com/releases/20171116222810/public_html/app/Mage.php:595
Stack trace:
#0 /var/www/code/www.oop.com/releases/20171116222810/public_html/app/code/core/Mage/Core/Model/Layout.php(495): Mage::throwException('Invalid block t...')
#1 /var/www/code/www.oop.com/releases/20171116222810/public_html/app/code/core/Mage/Core/Model/Layout.php(437): Mage_Core_Model_Layout->_getBlockInstance('page/html_top', Array)
#2 /var/www/code/www.oop.com/releases/20171116222810/public_html/app/code/core/Mage/Core/Model/Layout.php(472): Mage_Core_Model_Layout->createBlock('page/html_top', 'header.catsearc...')
#3 /var/www/code/www.oop.com/releases/20171116222810/public_html/app/code/core/Mage/Core/Model/Layout.php(239): Mage_Core_Model_Layout->addBlock('page/html_top', 'header.catsearc...')
#4 /var/www/code/www.oop.com/releases/20171116222810/public_html/app/code/local/Eyemagine/Template/Model/Core/Layout.php(46): Mage_Core_Model_Layout->_generateBlock(Object(Mage_Core_Model_Layout_Element), Object(Mage_Core_Model_Layout_Element))
#5 /var/www/code/www.oop.com/releases/20171116222810/public_html/app/code/core/Mage/Core/Model/Layout.php(205): Eyemagine_Template_Model_Core_Layout->_generateBlock(Object(Mage_Core_Model_Layout_Element), Object(Mage_Core_Model_Layout_Element))
#6 /var/www/code/www.oop.com/releases/20171116222810/public_html/app/code/core/Mage/Core/Model/Layout.php(210): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))
#7 /var/www/code/www.oop.com/releases/20171116222810/ee/third_party/mage_header/pi.mage_header.php(241): Mage_Core_Model_Layout->generateBlocks()
#8 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Template.php(1620): Mage_header->get_before_body_end()
#9 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Template.php(1231): EE_Template->process_tags()
#10 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Template.php(508): EE_Template->tags()
#11 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Template.php(211): EE_Template->parse('{!-- ra:0000000...', true, '3', false)
#12 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Template.php(884): EE_Template->fetch_and_parse('_embeds', '_footer', true, '3')
#13 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Template.php(556): EE_Template->process_sub_templates('{!-- ra:0000000...')
#14 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Template.php(211): EE_Template->parse('{!-- ra:0000000...', false, '', false)
#15 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Template.php(159): EE_Template->fetch_and_parse('', '', false)
#16 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/libraries/Core.php(709): EE_Template->run_template_engine('', '')
#17 /var/www/code/www.oop.com/releases/20171116222810/ee/system/expressionengine/controllers/ee.php(68): EE_Core->generate_page()
#18 [internal function]: EE->index()
#19 /var/www/code/www.oop.com/releases/20171116222810/ee/system/codeigniter/system/core/CodeIgniter.php(329): call_user_func_array(Array, Array)
#20 /var/www/code/www.oop.com/releases/20171116222810/public_html/community/index.php(199): require_once('/var/www/code/w...')
#21 {main}

I've been trying to clean up my exception.log and system.log but I'm not familiar with this particular error in exception.log.

config.xml

<?xml version="1.0"?>
    <config>
        <modules>
            <Eyemagine_Template>
                <version>1.0.6</version>
            </Eyemagine_Template>
        </modules>
        <global>
            <blocks>
                <eyemagine_template>
                    <class>Eyemagine_Template_Block</class>
                </eyemagine_template>
                <page>
                    <rewrite>
                        <html_topmenu>Eyemagine_Template_Block_Page_Html_Topmenu</html_topmenu>
                    </rewrite>
                </page>
                <page>
                    <rewrite>
                        <html_footer>Eyemagine_Template_Block_Page_Html_Footer</html_footer>
                    </rewrite>
                </page>
            </blocks>
            <models>
                <eyemagine_template>
                    <class>Eyemagine_Template_Model</class>
                </eyemagine_template>
                <core>
                    <rewrite>
                        <layout>Eyemagine_Template_Model_Core_Layout</layout>
                    </rewrite>
                </core>
                <enterprise_pagecache>
                    <rewrite>
                        <processor>Eyemagine_Template_Model_Enterprise_PageCache_Processor</processor>
                    </rewrite>
                </enterprise_pagecache>
                <enterprise_pagecache>
                    <rewrite>
                        <container_advanced_quote>Eyemagine_Template_Model_Enterprise_PageCache_Container_Advanced_Quote</container_advanced_quote>
                    </rewrite>
                </enterprise_pagecache>
            </models>
            <helpers>
                <eyemagine_template>
                    <class>Eyemagine_Template_Helper</class>
                </eyemagine_template>
            </helpers>
            <resources>
                <eyemagine_template_setup>
                    <setup>
                        <module>Eyemagine_Template</module>
                    </setup>
                </eyemagine_template_setup>
            </resources>
            <page>
                <layouts>
                    <home translate="label">
                        <label>Home</label>
                        <template>page/home.phtml</template>
                        <layout_handle>page_home</layout_handle>
                    </home>
                    <my_account translate="label">
                        <label>My Account</label>
                        <template>page/my-account.phtml</template>
                        <layout_handle>page_my_account</layout_handle>
                    </my_account>
                </layouts>
            </page>
        </global>
        <frontend>
            <layout>
                <updates>
                    <eyemagine_shippingmessage module="template">
                        <file>eyemagine/template.xml</file>
                    </eyemagine_shippingmessage>
                </updates>
            </layout>
        </frontend>
        <stores>
            <admin>
                <design>
                    <package>
                        <name>default</name>
                    </package>
                    <theme>
                        <default>frontier</default>
                    </theme>
                </design>
            </admin>
        </stores>
    </config>

any of these?

enter image description here

1

The easiest will be to search your new module for occurance of "html_top". If you will find any, you should probably replace it with html_topmenu.

If it won't help, please paste here your layout xmls, so we can analyse it.

1

You need to check the layout file for the same module in which you are facing this issue. In layout file you need to pass the block name and in following way-

<block type="block handel/block path" name="name for block" as="block name" template="template path">

like-

<block type="featured/featured" name="featured_featured" as="feature" template="ecom/featured.phtml">

And if you are trying to create the block through the controller then you may take help from following link- How to diagnose "Invalid block type .." error?

  • This layout file Eyemagine/Template/Model/Core/Layout.php(46)? Or the actual xml layout file for this module? @mudit-cedcommerce – getData Nov 23 '17 at 16:49
  • Still looking for some additional help here. Which module layout file? It doesn't specifically list one for Eyemagine/Template/Model/Core/Layout.php unless i'm looking in the wrong directories. I posted two directorys above but not sure which one pertains to error. – getData Nov 26 '17 at 1:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.