4

Before you mark this thread as duplicate please read the following:

I'm having a hard time getting to Connect manager
I tried all possible solutions from similar threads like:

  • Changing folder and file permissions for downloader directory(755 for dir,644 for file)
  • flushing cache(although i didn't delete it, just did the "Clear magento cache
  • from admin panel")
  • i did permission reset for directories so all permissions are having default values.
  • tried to access manager directly(mysite.com/downloader/index.php)

I'm getting desperate... I hope there is someone to help me solve this problem.

Magento ver is 1.9.1.0

  • Can you have a look at the log files and share them here? I also would like to see the network and console tab within your chrome developer console. – David Lambauer Nov 21 '17 at 19:14
  • Thanks for showing interest for my problem. Console is empty so i'll skip that part. Exception log - ufile.io/wg93q – Dusko Nov 21 '17 at 19:40
  • ibb.co/mwptL6 - network tab – Dusko Nov 21 '17 at 19:47
  • Could you also provide the PHP and web server error logs, please? – David Lambauer Nov 21 '17 at 22:19
  • I've only found this one ufile.io/rzpbd , it's location was in var/logs which is child folder of public_html. It's a linux based server, and there is a folder log which only shows ip address activity, nothing else, also it's a shared hosting... – Dusko Nov 21 '17 at 22:57
1

With the information you gave me and those I found during my research, your problem should be solved by following the steps I provide below:

  • Check file permissions in the downloader directory.

    • chmod -R 755 downloader/ && chmod 644 downloader/index.php
  • Clear your cache.

    • rm -Rf var/cache/*
  • Check the state of the module.

    • The module must not be disabled. To check that, go into app/etc/modules
  • Make sure the file app/code/core/Mage/Connect is available.

  • If you still not be able to access the connect manager, try to access it directly via example.com/downloader/index.php.

  • Already tried all of that, nothing changes... Permissions are ok, cache is cleared. Mage_Connect.xml is set as true, app/code/core/Mage/Connect is available, direct access doesn't help. it still says 404 Not Found. :( – Dusko Nov 22 '17 at 15:18
  • ufff, hard one here... What about the webserver error logs? – David Lambauer Nov 22 '17 at 16:25
  • I've found solution and set it as answer :) – Dusko Nov 22 '17 at 17:23
0

Hooorayy, i've found the answer.Uploading downloader folder from another installation fixed this problem. Thanks for your effort.

  • This is not a solution. Now you don't know what caused the problem in the first place... – Yiorgos Moschovitis Nov 22 '17 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.