0

I recently installed an SSL certificate on my test server and I got a problem with my front end. All the web pages return 404 if I don't put /index.php/.

I put Use Web Server Rewrites as No and Use Secure URLs in Frontend as Yes but nothing works.

Please help..

  • Hi, make sure you have url_rewrite extension enabled in your server. – Meetanshi Nov 21 '17 at 16:06
  • Use Web Server Rewrites - YES, check you have .htaccess – MagenX Nov 22 '17 at 9:22
0

As @Meetanshi said, make sure you have mod_rewrite enabled on the server or not. mod_rewrite should be enabled to allow URLs without index.php.

To check whether it is enabled or not, do one of the following:

Method 1: Create a file (say: info.php) in the document root and paste below code:

<?php
phpinfo();
?>

Now hit the URL yourwebsiteurl/info.php and check for mod_rewrite under Loaded Modules section. If it does not exist, it means that server does not have mod_rewrite (URL rewrites) enabled.

Method 2: Write anything wrong in the .htaccess file under document root and reload the website.

If mod_rewrite is enabled, then you should get Internal Server Error. If it does not happen, you must enable mod_rewrite on the server.

To know how to enable mod_rewrite, you can check instructions here.

Please let me know if it helped.

  • Thanks all, you are right mod_rewrite was disable on my server, I activated it on my Apache, restarted it and work well now. – Rafael David Portilla Santigue Nov 22 '17 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.