1

I have migrated Magento 1.9 data to Magento 2 using data migration tool. Data migrate successfully completed.

When I log in to admin dashboard that time all product showing correctly.

When I searched product that time product is not displaying in the list page. But I am directly put URL key in front of the domain name that time product is display.

I have tried following things,

 A product is set to enabled under a status
 A product is set to catalog (and search) under visibility 
 A product has qty (in stock) and set to in stock
 A product is attached to a category
 Then run an "Empty cache" and a re-index.
  • did you run setup upgrade and static content deploy command? – Abhishek Panchal Nov 20 '17 at 22:07
  • yes i did @abhishesk – pramod24 Nov 21 '17 at 4:55
1

Make sure products are added to the website. Same thing happened to me

Catalog > Products | Select All

Then on the Options dropdown, "Update Attributes" > Select the "Websites" tab on the left. Check the boxes under "Add Product to Websites" > Save

Might have to clear cache after. But that's what worked for me. Even though the DB was showing the field correctly, running the update fixed it for me.

I hope it works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.