1

I am new in magento2. I have created one new custom module. I have installed custom module. after installing website showing all pages blank.

after installing i run following commands.

  php bin/magento module:enable module name
  php bin/magento setup:upgrade
  php bin/magento cache:clean

when i run this command then website showing all pages blank.

1 Answer 1

2

Try adding this to your index.php file to show errors:

ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);
error_reporting(-1);

ini_set('error_reporting', E_ERROR);
register_shutdown_function('fatal_handler');
function fatal_handler()
{
    $error = error_get_last();
    echo ('<pre>');

    var_dump($error);
}

This will enable errors within magento, also check server log files

2
  • Thanks @ ThisGuyHasTwoThumbs
    – pramod24
    Commented Nov 20, 2017 at 17:02
  • no worries @santosh :)
    – treyBake
    Commented Nov 20, 2017 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.