0

This question already has an answer here:

My site is www.suresafety.com which is in Magento 1.9.2.0. It was working fine for the last 1.5 years, but from the last 2 months, it is too much slow. There are 1400 products in it.

Its speed in Speed Insight was 83 before 1 year. Now it is 39 which is not good for our e-commerce.

I have done all this on steps:

  1. Combine CSS and JS Files

    • In the Magento Admin, go to System > Configuration > Developer.
    • Under “Javascript Settings”, change “Merge Javascript Files” to YES.
    • Under “CSS Settings”, change “Merge CSS Files” to YES.
    • Clear the cache.
  2. Enable Flat Catalog

    • In the Magento Admin, go to System > Configuration > Catalog.
    • Under “Frontend”, change “Use Flat Catalog Category” to YES.
    • Under “Frontend”, change “Use Flat Catalog Product” to YES. (optional)
    • Clear the cache.
  3. Make sure the section with the deflate compression rules is not commented to enable the default compression rules.

    <IfModule mod_expires.c>
    
        ## enable apache served files compression
        ## http://developer.yahoo.com/performance/rules.html#gzip
    
        # Insert filter on all content
        ###SetOutputFilter DEFLATE
        # Insert filter on selected content types only
        AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript
    
        # Netscape 4.x has some problems...
        BrowserMatch ^Mozilla/4 gzip-only-text/html
    
        # Netscape 4.06-4.08 have some more problems
        BrowserMatch ^Mozilla/4\.0[678] no-gzip
    
        # MSIE masquerades as Netscape, but it is fine
        BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    
        # Don't compress images
        SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary
    
        # Make sure proxies don't deliver the wrong content
        #Header append Vary User-Agent env=!dont-vary
    
    </IfModule>
    
  4. Add expiration time for images, JS, CSS (.htcaccess)

    ##for image test
    <IfModule mod_expires.c>
    
        ExpiresActive On<br/>
        ExpiresByType image/jpg "access 1 year"<br/>
        ExpiresByType image/jpeg "access 1 year"<br/>
        ExpiresByType image/gif "access 1 year"<br/>
        ExpiresByType image/png "access 1 year"<br/>
        ExpiresByType text/css "access 1 month"<br/>
        ExpiresByType text/html "access 1 month"<br/>
        ExpiresByType application/pdf "access 1 month"<br/>
        ExpiresByType text/x-javascript "access 1 month"<br/>
        ExpiresByType application/x-shockwave-flash "access 1 month"<br/>
        ExpiresByType image/x-icon "access 1 year"<br/>
        ExpiresDefault "access 1 month"<br/>
    
    </IfModule><br/>
    
  5. Cpanel -> Optimize Website -> tic on 2nd option(Compress all content)

  6. Download optimized images, CSS, JS from Page Insights (bottom)

  7. Replace with the old one.

marked as duplicate by Manoj Deswal, Prince Patel, Siarhey Uchukhlebau, Piyush, Manashvi Birla Nov 20 '17 at 5:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

This as a duplicate question of: Site loading speed is very slow.

For the Magento htaccess, you can use our htaccess based on html5boilerplate htaccess. see below: https://gist.github.com/reillo/9030038e854ffa49d83e423415c7acf4

Magento requires server resources and if you think you have enough server resources, you can check your Magento Application performance using a profiler. You can use the profiler from Aoe_Profiler.

Not the answer you're looking for? Browse other questions tagged or ask your own question.