0

I have check the visibiity option and status of that product is also enabled and also reindex the data but still one product is returning 404 error.

https://qa2.yeswellness.com/vitamins-and-minerals/greens-and-antioxidants/chlorella.html.Check first product on the list.

1

2 Answers 2

0

Have you checked the stock-settings? Per default Magento creates new products as "out of stock" and this one might still be on the default settings. Open the product in the admin panel, head for inventory and check if everything is good. If you changed something, reindex data and all should be fine.

7
  • yes I have checked this one as well and product is in stock
    – nikita
    Nov 17, 2017 at 10:17
  • Have you checked visibility settings on all available levels (website, store and storeview)? How are your products created? Is the product assigned to the right website and category? Sadly I get a 403 Forbidden when trying to open your site. Nov 17, 2017 at 10:21
  • From where can i check the visibility settings ? i am newbie to the magento so i dont have much information about it?
    – nikita
    Nov 17, 2017 at 10:39
  • Its on the product edit page in the admin panel right in the general section under then URL-Key part. It has 4 options (nothing, search only, catalog only or both). Nov 17, 2017 at 10:51
  • It is set to the catalog right now, is it corect?
    – nikita
    Nov 17, 2017 at 10:53
0

Verify that the following category is enabled: Greens and Antioxidants
If enabled, verify that you have the correct URL_KEY for the category in your URL.

The product may be enabled and you could be using the wrong URL.

This category loads: https://www.yeswellness.com/vitamins-and-minerals.html
This one does not: https://www.yeswellness.com/vitamins-and-minerals/greens-and-antioxidants.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.