0

When I change the Meta Keywords in Search Engine Optimization and check the result with the Developer Tools of my browser, I can't see any change.

I tried removing the browser cache and cleaning Magento this way:

cd /var/www/html/MAGENTO_FOLDER
rm -rf var/cache/* var/di/* var/generation/* var/page_cache/* var/view_preprocessed/* pub/static/frontend/*
php bin/magento cache:clean
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento indexer:reindex
php bin/magento cron:run

But it doesn't solve the issue.

Is it a bug from Magento 2.2 or is there something else I should do to refresh the Meta Keywords tags ?

6
  • If you are running varnish this would also need to be refreshed. Is this a custom theme or luma/blank?
    – Eirik
    Nov 17, 2017 at 1:17
  • It's a custom theme
    – DevonDahon
    Nov 17, 2017 at 1:26
  • As a quick test, switch to luma or blank and refresh the cache etc and check if it is updating.
    – Eirik
    Nov 17, 2017 at 1:43
  • The problem came from the scope, I was editing at scope "All Store Views" while I have to edit at the scope of the specific store view my website is using. Magento is opening the product at scope "All Store Views" by default, which is a bit troublesome, I don't know if there's a way to disable this "All Store Views" scope.
    – DevonDahon
    Nov 17, 2017 at 2:04
  • Magento 2 has a setting for running as a single store but I think you'll still run into the store view issue.
    – Eirik
    Nov 17, 2017 at 2:20

1 Answer 1

0

I have more than one website and I was editing the product in "All Store Views" of a website, instead of selecting the "Store View" of the website.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.