2

Got this error, no clue how to upgrade:

- magento/product-community-edition 2.2.0 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1] but these conflict with your requirements or minimum-stability.

my composer.json

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.2.0",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/product-community-edition": "2.2.0",
        "composer/composer": "1.1.2 as 1.0.0-beta1",
        "iwd/ordermanager": "2.6.0",
        "hellobrave/cookiecompliance": "1.0.4",
        "clarion/customer-attribute": "1.0.0",
        "extait/admin-notify": "1.0.3",
        "amasty/base": "1.0.6",
        "amasty/groupcat": "1.3.1",
        "aheadworks/module-rbslider": "1.1.5"
    },
    "require-dev": {
        "phpunit/phpunit": "4.1.0",
        "squizlabs/php_codesniffer": "1.5.3",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.2.2",
        "fabpot/php-cs-fixer": "~1.2",
        "lusitanian/oauth": "~0.3 <=0.7.0",
        "sebastian/phpcpd": "2.0.0"
    },
    "config": {
        "use-include-path": true
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": "app/code/"
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": "app/code/"
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "alpha",
    "prefer-stable": true,
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://repo.magento.com/"
        },
        "magento": {
            "type": "composer",
            "url": "https://repo.magento.com/packages.json"
        }
    },
    "extra": {
        "magento-force": "override"
    }
}
  • composer show -i says composer/composer 1.1.2 Composer helps you declare, manage and install dependencies of PHP projects, ensuring you have the right stack everywhere. – Sam Provides Nov 16 '17 at 10:44
  • I have no idea how to upgrade this composer/composer component package – Sam Provides Nov 16 '17 at 10:44
  • Getting the same problem, have you found anything more yet? – Thomas Meier Nov 16 '17 at 15:34
1

Step 1: Access Your Server via SSH

You need to connect your server via SSH.

Step 2: Navigate to the Magento 2 Root Directory

Once your SSH connection is up, you will need to move to your target application folder. In that application folder, you will find the public_html folder which is the root directory of Magento 2.

Step 3: Upgrade Commands

composer require magento/product-community-edition 2.2 --no-update

Then execute this all commands

 composer update
 rm -rf var/di var/generation
 php bin/magento setup:upgrade
 php bin/magento setup:di:compile
 php bin/magento cache:clean
 php bin/magento cache:flush
 php bin/magento indexer:reindex
| improve this answer | |
  • To get to our problem we already had to go through steps 1 & 2. The error occurs when running composer update – Thomas Meier Nov 17 '17 at 8:11
1

After some research I found the solution...

Apparently changing your composer to was a workaround for updating an earlier version of Magento. But nobody really bothered to revert the change after updating it.

 "composer/composer": "1.1.2 as 1.0.0-beta1"

So now we should revert the composer.json to its initial state, which is:

"composer/composer": "@alpha"

It solved the issue for me, I hope it can help anyone else!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.