2

can anyone help me to how to move customoptions section to below the product descriptions section.

Please find the screenshot below:

enter image description here

Thanks

1 Answer 1

0

Firstly, create your own default.xml in view/frontend/layout with the content below:

<?xml version="1.0"?>
<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
    <body>
        <move element="product.info.options.wrapper" destination="product.info.options.container"/>
        <referenceContainer name="product.info.main">
            <container name="product.info.options.container" htmlTag="div" htmlClass="product.info.options.container" after="product.info.price"/>
        </referenceContainer>
    </body>
</page>

Don't forget remove var/gerenation. Here is my result. Hope it help you! enter image description here

EDIT: I have make a mistake. The removing product.info.options.wrapper make the option select out of form. So the product can validate for add to cart. Please undo the previous change and do the following way:

1.Add new file name catalog_product_view_type_downloadable.xml to override the core layout. Then add the below code:

<?xml version="1.0"?>
<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
    <body>
        <move element="product.info" destination="product.info.main" after="alert.urls"/>
    </body>
</page>

The effect not much beautiful so you have to add your own CSS file to restyle it. This is my result. enter image description here

Now, the option will take right price.

23
  • Hi, its working but for dropdown custom options price is not updating Nov 15, 2017 at 4:46
  • Could you show me the options?
    – Nero Phung
    Nov 15, 2017 at 5:54
  • Hi find the screenshot:prnt.sc/hamznl Nov 15, 2017 at 6:07
  • Seem like you are using firefox. F12 and check Network to see what happen when change the select box.
    – Nero Phung
    Nov 15, 2017 at 6:22
  • it seems like:prnt.sc/han52j Nov 15, 2017 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.