0

I only use simple products. Some of my product pages are set to one column and some are set to 2 columns right. I want all of them set to one column. I have a child theme that uses the catalog_product_view.xml. I have used to move blocks around, and everything works. I added layout="1column" to the page so it looks like this

page layout="1column" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd"

And it doesn't work. I have flushed the cache but it hasn't made any difference. How can I set all product pages to just use one column layout?

1 Answer 1

0

You can set product page one column with using below options in your child theme :

1) Magento_Catalog/view/frontend/layout/catalog_product_view.xml

<page layout="1column" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">

2) From Admin panel :- Product -> Catalog -> Edit Product -> Design -> Layout option

You need to check in admin panel for that particular product which layout is different from 1 column & select no layout update value because it will override catalog_product_view.xml settings.

1
  • I did set it to the 1 column and it didn't help. I went to where you said and it was set to the wrong layout, I switched it and it fixed it. I ran across this -magento.stackexchange.com/questions/166583/… and he was having the same issue and it was due to the migration. I want to check the database like he did but don't have the reputation to ask him which table it is. Do you happen to know?
    – tjjen
    Commented Nov 10, 2017 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.