2

Whenever I try to create new customer account from home page, the page refreshes after submit and nothing is submitted. There is no any error message.

I have check the register.phtml file in module-customer and it has form key as follow.

<?php /* @noEscape */ echo $block->getBlockHtml('formkey'); ?>

However, my app/design/frontend/Magento folder is empty and does not contain any files.

  • In which browser you are facing issue ? – Yogesh Nov 7 '17 at 9:08
  • Please use ip rather than localhost – Yogesh Nov 7 '17 at 9:15
  • @Yogesh i have configure /etc/hosts so that www.test.com will point to localhost but it still redirect back to localhost for magento. Do note that i have wordpress file hosted in localhost as well but it do not redirect back to localhost. Where else do i need to change – vincentsty Nov 7 '17 at 9:43
  • you need to setup virtual host for that, you can change your url youripaddress/magento-ce-2-2 – Yogesh Nov 7 '17 at 9:45
  • 2
    You are not able to login with localhost in chrome browser – Yogesh Nov 7 '17 at 9:57
1

You need to use your ip/yourmagentofolder instead of localhost and change same in "core_config_data" table in secure/unsecure url .

If you are using virtual host than point your virtual host to your IP instead of localhost .

And don't forget to clear cache .

| improve this answer | |
0

You need to go to your database localhost/ then you look for the core_config_data table change all the localhost to your IP.

Then go to your Magento project <project folder>/app/etc in this folder you have the env.php file, change the localhost to your IP.

Then clear your cache

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.