0

We have implemented https on our Magento store a few months back and everything seems fine exceptive noted that the server response for 301 redirects don't seem to be honoring the https://

The server response is similar to this.


Location: http://www.example.com

Redirecting to: http://www.example.com


This is then leading critters to HTTP versions of the page then a 301 to the https version, creating a loop.

Is this correct or is something wrong causing the server to output http and not https?

2 Answers 2

0

Change both admin panel URL in https version.

web/unsecure/base_url

web/secure/base_url

and place below code in htacess

RewriteCond %{HTTP_HOST} ^www.example.com$ [NC] RewriteRule (.*) https://www.example.com/$1 [R=301,L]

So all crawl URL will redirect to https URL.

3
  • Hi, I have already done this but it still keeps showing as http in the htaccess 301 redirects
    – Michael
    Nov 7, 2017 at 8:54
  • not getting you. Please clarify more.
    – Yogesh
    Nov 7, 2017 at 8:57
  • Hi Have already added the htacces code and changed base urls but still when we use htaccess to 301 redirect URLs it redirects to the http versions of the page and not https.
    – Michael
    Nov 7, 2017 at 9:27
0

I fixed the issue by setting the cookie setting in the backend of magento and this fixed my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.