1

Over the last few days my exception log has become full of entries of the following:

2017-11-06T09:27:13+00:00 ERR (3):
exception 'Mage_Core_Model_Session_Exception' in mag19/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php:421
Stack trace:
#0 mag19/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(236): Mage_Core_Model_Session_Abstract_Varien->validate()
#1 mag19/app/code/core/Mage/Core/Model/Session/Abstract.php(84): Mage_Core_Model_Session_Abstract_Varien->init('tag', NULL)
#2 mag19/app/code/core/Mage/Tag/Model/Session.php(38): Mage_Core_Model_Session_Abstract->init('tag')
#3 mag19/app/code/core/Mage/Core/Model/Config.php(1357): Mage_Tag_Model_Session->__construct(Array)
#4 mag19/app/Mage.php(463): Mage_Core_Model_Config->getModelInstance('tag/session', Array)
#5 mag19/app/Mage.php(477): Mage::getModel('tag/session', Array)
#6 mag19/app/code/core/Mage/Core/Controller/Varien/Action.php(641): Mage::getSingleton('tag/session')
#7 mag19/app/code/core/Mage/Core/Controller/Varien/Action.php(665): Mage_Core_Controller_Varien_Action->_initLayoutMessages(Array)
#8 mag19/app/code/core/Mage/Catalog/Helper/Product/View.php(146): Mage_Core_Controller_Varien_Action->initLayoutMessages(Array)
#9 mag19/app/code/core/Mage/Catalog/controllers/ProductController.php(132): Mage_Catalog_Helper_Product_View->prepareAndRender(1467, Object(Mage_Catalog_ProductController), Object(Varien_Object))
#10 mag19/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Catalog_ProductController->viewAction()
#11 mag19/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('view')
#12 mag19/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#13 mag19/app/code/core/Mage/Core/Model/App.php(365): Mage_Core_Controller_Varien_Front->dispatch()
#14 mag19/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#15 mag19/index.php(87): Mage::run('', 'store')
#16 {main}

I have not touched any code to do with sessions and will be the default code, so I am confused as to why this is occurring. If anyone could help to solve this I would thoroughly appreciate it.

2

You have a similar issue than this one:

https://magento.stackexchange.com/a/167834/17293

Try to to add

return true; 

before

if ($this->useValidateSessionExpire()

in the file app/code/core/Mage/Core/Model/Session/Abstract/Varien.php

Also try to keep an eye on this Github issue, may be a better fix can be provided or you can share your feedback:

https://github.com/OpenMage/magento-lts/issues/394

Not the answer you're looking for? Browse other questions tagged or ask your own question.