I have been searching for hours, trying to avoid the "already asked and answered" and the "LMGTFY" remark. The problem is, all the answers I'm finding are either not applicable to my environment (I'm not running Vagrant, WAMPP/XAMPP/MAMPP, and I haven't installed anything on top of, updated, or otherwise fiddled with Magento at all) or the suggested solutions are not my problem (the .htaccess file is already in the docroot, user:group is already set to www-data:www-data, app/etc/use_cache.ser doesn't exist, therefore, cannot be deleted). So, if I've somehow overlooked the fix, please accept my apology and just point me to the right place.

This is a brand new, fresh install of Magento 2 (Magento-CE-2.1.9-2017-09-13-03-35-18.tar.gz to be exact) running on a dedicated Ubuntu 16.04 x64 server running on a DigitalOcean droplet. This is a development server that will only be accessed via IP and eventually moved to a permanent host. Listed are the steps I took. At the end of the web-based setup, I hit the big, orange "Launch Admin" button, and got a 404 error. I added /admin/ to the URL, then I added /admin/index.php ... neither worked. Yes, I made sure I was using the correct "admin" username.

  1. Ensured LAMP stack in place
  2. Added user 'magento' to mysql and granted all permissions. (GRANT ALL ON magento.* to magento@localhost; FLUSH PRIVILEGES; etc)
  3. To /etc/apache2/sites-available/000-default.conf, I added:

     DocumentRoot /var/www/html // added for clarity
     // Open bracket not showing up, even when using  &  tags
    -open bracket -Directory /var/www/html>
     Options Indexes FollowSymLinks Multiviews
     AllowOverride All
     Order allow,deny
     allow from all

  4. apache2ctl configtest (Syntax OK)

  5. Restarted apache
  6. tar xvzf Magento-CE-2.1.9-2017-09-13-03-35-18.tar.gz (from docroot: /var/www/html)
  7. chown -R www-data:www-data /var/www/html
  8. chmod -R 755 /var/www/html // on a previous attempt, I set the entire tree to 777
  9. Fired up the browser, ran http:/xxx.xxx.xxx.xxx/setup
  10. Passed all checkpoints and web portion of setup successfully completed
  11. Hit "Launch Admin", got 404
  12. Checked front page - content visible, appears to be missing CSS.

This wasn't my first attempt. I actually verified these with an instruction video, so I could be sure I covered everything.

I apologize for the long read, and I've tried to take most of the frustration out of my tone, but I've never had so much trouble installing anything. Ever.

  • Look for frontName inside app/etc/env.php then try to open yoursite/index.php/[value of frontName] Commented Nov 5, 2017 at 18:52
  • Confirmed that the 'frontName' is what I've been using. Added the 'index.php' between the yoursite value and [value of frontName]. Still have a 404. Commented Nov 5, 2017 at 19:20
  • It looks to me like .htaccess issue, can you temporary remove it and reopen the page? Commented Nov 5, 2017 at 19:24
  • Did you mean remove the .htaccess file from the docroot? If so, the following changes occured: The original 404 displayed in a sans-serif font, and read, "404 error: Page not found." After removal (I actually renamed the file) of the .htaccess file, a non-styled generic page showed, "Not Found The requested URL /xxxxx/ was not found on this server. Apache/2.4.18 (Ubuntu) Server at xxx.xxx.xxx.xxx Port 80" Commented Nov 5, 2017 at 19:41
  • so the page displayed when htaccess is present is magento 404 page. Somehow it has no idea you are trying to access it's backend. Is apache rewrite module on? Commented Nov 5, 2017 at 19:46

1 Answer 1


Apache rewrite module is not enabled.

  • I was so focused the things I didn't try! Thank you so much, Zivorad! Commented Nov 5, 2017 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.