1

I am also facing the same issues after upgrading the magento version from version 1.9.2 to version 1.9.3.6 ...pages simply show flas.. your help would be much appreciable.

Thanks

enter image description here

2

Here is my Code for the registration:

<form action="https://www.my-example.com/customer/account/createpost/" method="post" id="form-validate">
        <div class="fieldset">
            <input type="hidden" name="success_url" value="">
            <input type="hidden" name="error_url" value="">
            <input type="hidden" name="form_key" value="w5aGzmiwvqzKXllY">
            <h2 class="legend">Daten Ansprechpartner</h2>
            <ul class="form-list">
                <li class="fields">

In your code it is missing:

<form action="http://your-example.com/customer/account/createpost/?SID=91i3p974p1jtggdljian86v925" method="post" id="form-validate" class="register-form">
        <div class="fieldset">
            <input type="hidden" name="success_url" value="">
            <input type="hidden" name="error_url" value="">
            <h2 class="legend">Personal Information</h2>
            <ul class="form-list">
                <li class="fields">
                    <div class="customer-name-middlename">
    <div class="field name-firstname">

I find the formkey for the login but not for registration. Try to find the right path for the .phtml with the simlinks.

5
  • i used this form key code <div><input name="form_key" type="hidden" value="<?php echo Mage::getSingleton('core/session')->getFormKey() ?>" /></div> in this path app/design/frontend/default/sm_macy/template/customer/form/register.phtml and app/design/frontend/default/sm_macy/template/customer/form/register.phtml and app/design/frontend/base/default/template/persistent/customer/form/register.phtml but there is not result still the register pages just refresh only .........any help would be much appreciable .........thanks Nov 6 '17 at 6:24
  • can you try to check with the magento debug. Like this: magento.stackexchange.com/questions/90117/… You can block all other if you put your IP in allowed IP's. Then you can see the path of the register.phtml maybe there is a another path couse there is only a formkey in your quick access on the register site.
    – Marcel
    Nov 6 '17 at 8:20
  • I have added form key in this path as per you given instructions app/design/frontend/default/sm_macy/template/persistent/customer/form/register.phtml but i dont know why it is not showing when i do inspect element ..... Nov 6 '17 at 8:45
  • change fast the debug becouse it is open for all!!!! I can see the path and so on.
    – Marcel
    Nov 6 '17 at 8:52
  • Please download the frontend/default/sm_macy/template/persistent/customer/form/register.phtml via ftp and make sure that the change have really occurred
    – Marcel
    Nov 6 '17 at 9:15
1

Have you editet the register.phtml formkey? (In your custom template) If it is so here is a way to solve the problem: https://community.magento.com/t5/Technical-Issues/Customer-Registration-not-working-in-1-9-2-2/td-p/20563

20
  • /app/design/frontend/default/sm_macy/template/persistent/customer/form/register.phtml Nov 3 '17 at 12:11
  • i edit the files in this code Nov 3 '17 at 12:11
  • /app/design/frontend/default/sm_macy/template/persistent/customer/form/register.phtml but it not helps me .. Nov 3 '17 at 12:12
  • You have to edit this: 1) app/design/frontend/[your_custom_theme]/template/customer/form/register.phtml 2) app/design/frontend/[your_custom_theme]/template/customer/form/resetforgottenpassword.phtml 3) app/design/frontend/[your_custom_theme]/template/persistent/customer/form/register.phtml 3) app/design/frontend/[your_custom_theme]/template/persistent/customer/form/login.phtml
    – Marcel
    Nov 3 '17 at 12:17
  • i have edited as per given your links ....but still not result found after edited the code i did the caches clears but nothing changes got effects.... Nov 3 '17 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.