• In my case, after enable the path Hints, from magento2 back-end section, its not showing. I enabled the settings in.

    Store > Configuration > Advanced > Debug > Enabled Template Path Hints for Storefront > Yes

    Can anyone tell me how fix this ?

    enter image description here

  • Yes, I already select to scope .but it seems not fixed. Commented Nov 2, 2017 at 8:59
  • Are you in production mode ? Commented Nov 2, 2017 at 9:00
  • No,working on local server. Commented Nov 2, 2017 at 9:03
  • You need to set Default Store view instead of Main website in your current scope. Commented Nov 2, 2017 at 9:06
  • 6
    m2.3 use storurl/?templatehints=magento
    – matinict
    Commented Mar 27, 2019 at 7:47

8 Answers 8


As @matinict mentioned in his comment, in Magento 2.3 you need to append ?templatehints=<Parameter Value> in your URL and your magento should be on Developer mode.

So your url will be look like as following:


and for any particular page URL will be like that


enter image description here

  • it works for me
    – Alam Zaib
    Commented Aug 22, 2019 at 5:23

For future googlers - I had this same problem on a site that had the core Magento data migrated over from an M1 store I had no control over. The problem turned out to be an IP address in the developer client restrictions input. This overrides template hints.

developer ip restrictions input in Magento 2 admin area

  • 1
    This worked for me. Commented Dec 19, 2018 at 10:10
  • 1
    Thanks, this worked for me. Commented May 13, 2019 at 10:24
  • 2
    Does not work, it still not shows. Edit: I had to set the store view to my store view in the upper left. There were also IP's entered in it.
    – Black
    Commented Oct 22, 2019 at 8:09
  • 1
    @Black cool, this was also my case. Commented Dec 17, 2019 at 13:07
  • this worked for me Commented Dec 28, 2020 at 4:43

You need to set scope Default store view or your current store view. You have set Main Website in Current configuration scope.

enter image description here

After set Current configuration as YOur Default store view and check Yes for storepath hints for front and Blockpath hints as Yes.

  • thnks to all, its worked. Commented Nov 2, 2017 at 9:22
  • Thanks! My problem was also wrong scope
    – bdbdbd
    Commented Oct 27, 2021 at 16:01

If you are using Magento 2.2 then on production mode, the template hint will not work.

Also, you need to check the setting at last level of scope mean store view scope.

  • How to view Template Path Hints for Storefront in Production Mode?
    – zus
    Commented Oct 14, 2020 at 3:42
  • You cannot do at Production. Need to some customization
    – Amit Bera
    Commented Oct 14, 2020 at 6:17
  • Can i get any idea how to do the customization regard path hints?
    – zus
    Commented Oct 14, 2020 at 6:29

I strongly discourage this method. Use it at your own risk. Only to be used on local system.

Open vendor/magento/module-developer/Model/TemplateEngine/Plugin/DebugHints.php (tested in 2.3.2)

write this code inside afterCreate function : (at the start, above the storecode line)

if(isset($_GET['shreyasPathHints']) && $_GET['shreyasPathHints'] == 'on'){
    return $this->debugHintsFactory->create([
        'subject' => $invocationResult,
        'showBlockHints' => 1,

Now, you can open any Magento page and append ?shreyasPathHints=on to the URL. No need to run any commands.


Curiously. Now it works. Added a new block on the site and once again cleared the cache.


I'd like to put in my two cents as well. After scratching my head about why template hints weren't being displayed even though the setting is enabled, I eventually discovered that the ?templatehints={key} bit does not work with urls that include pagination, eg:


In this case, you would need to remove the ?p=1 portion of the url.


When I discovered my problem, I didn't know whether to laugh or cry with anger! haha

Basically when I activated templatehintes through the SHH console I had set an IP. I forgot to remove this IP. Obviously when my IP number changed, the template hints no longer worked.

I just needed to remove this IP and everything worked normally.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.