3

Magento 2.2 should be working with php 7.1, why do I get this error and how should I fix it ?

magento@me-dev:/var/www/html/me$ composer require magento2translations/language_zh_cn:dev-master ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/framework 100.0.18 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement.
    - magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.11) does not

satisfy that requirement. - magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.17 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.16 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.15 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.14 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.13 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento/framework 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.11) does not satisfy that requirement. - magento2translations/language_zh_cn dev-master requires magento/framework ~100.0 -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.1.9, 100.0.18]. - Installation request for magento2translations/language_zh_cn dev-master -> satisfiable by magento2translations/language_zh_cn[dev-master]. Installation failed, reverting ./composer.json to its original content.

0

If it doesn't work, you can install pack manually as follows.

Refer: https://github.com/Magento2Translations/language_zh_cn

To install this language package manually you need access to your server file system.

Download the zip file here.
Upload the contents to <your magento path>/app/i18n/magento2translations/language_zh_cn.
The composer files should then be located like this <your magento path>/app/i18n/magento2translations/zh_CN/zh_CN.csv.
Go to your Magento admin panel and clear the caches.
  • "php -v" gives me "PHP 7.1.11-1+ubuntu16.04.1+deb.sury.org+1 (cli)" – DevonDahon Nov 2 '17 at 4:24
  • You can install language pack manually as updated answer – Kishan Patadia Nov 2 '17 at 4:56
  • Thanks for your update, however, this language pack is often updated, this is why I'd prefer to install it with composer, to make updates easier. – DevonDahon Nov 2 '17 at 6:15
0

Another language pack worked just fine for Chinese language and is even more up-to-date:

composer require mageplaza/magento-2-chinese-language-pack:dev-master
php bin/magento cache:clean

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.