2

After running

composer require magento/product-community-edition 2.2.0 --no-update
composer update

I ran

bin/magento setup:upgrade

But while running this command I get the following error:

Updating modules:
Unable to unserialize value.
[InvalidArgumentException]
Unable to unserialize value.

I read that multiple developers had this problem after upgrading to Magento 2.2 and it could be a problem with installed extension, but for me there isn't any entry in the log files of Magento, PHP or MySQL.

1

This is the problem with your cache. Just cleared your magento cache. If you are using any third party cache like Redis, just flush it and try. It will fix this problem.

6
  • 1
    I forgot to mention that I ran: rm -rf <Magento install dir>/var/cache/* rm -rf <Magento install dir>/var/page_cache/* rm -rf <Magento install dir>/generated/code/* And if I want to run php bin/magento cache:clean it returns: There are no commands defined in the "cache" namespace. – torhoehn Oct 30 '17 at 17:46
  • Check you have provided proper permission to the generated and var folders – MGento Oct 30 '17 at 17:48
  • I got this error before and I was using Redis cache. When I flush my Redis cache, the error is gone. – MGento Oct 30 '17 at 17:49
  • I already ran this command in my Magento dir: find var generated vendor pub/static pub/media app/etc -type f -exec chmod u+w {} \; && find var generated vendor pub/static pub/media app/etc -type d -exec chmod u+w {} \; && chmod u+x bin/magento – torhoehn Oct 30 '17 at 17:52
  • I don't use any Redis cache. – torhoehn Oct 30 '17 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.